Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Can I completely disable "Recently Used" feature in GTK's file / directory selector?

Recently Used

Sometimes programs default to this but since it's not useful in my work-flow and with the way I organize my files, it only adds confusion:

  • I usually just expect to start from my $HOME, so I get surprised by the list of folders

  • Also in case of file saving, I'm annoyed by the fact that you can't just type in the name and hit Enter--you have to type a path or select one

I'm using Xfce 4.8 on Debian Wheezy and this feature was not available in older Xfce (in Squeeze). I found a post on Xfce-users' mailing list regarding this feature, but without any useful output.

Is it possible to simply turn this off and default to $HOME?

share|improve this question
Sadly it seems you're right. Although this is really a nasty thing to hard-code since it obviously breaks workflows like "Hit Ctrl+S, type filename, hit Enter". Hopefully one day it will change and we'll have answer... – Alois Mahdal Apr 30 '13 at 14:56
I wouldn't hold my breath... GTK/Gnome devs are known to be really stubborn (a classic example being the CTRL+DEL stupidity implemented in Nautilus). FWIW, wrt file chooser, I usually hit Ctrl+S, type filename then Ctrl+Tab then arrows (as many times as needed) then Enter. – don_crissti Apr 30 '13 at 16:50
up vote 5 down vote accepted


There is a file ~/.config/gtk-2.0/gtkfilechooser.ini. It should look like Stefano wrote:

[Filechooser settings]

There was no DefaultFolder variable in this file, but I found the StartupMode=recent var which I changed to StartupMode=cwd. This only works on GTK 2 applications like mousepad.

I don't know there is settings file for GTK 3 apps like gedit, but it seems that GTK 3 filechooser already sets the location to the current folder by default.

share|improve this answer

Note: This answer is for GTK3; all other answers only work for GTK2.

To disable the recent files list, add the following to ~/.config/gtk-3.0/settings.ini (create it and its directory if needed):


To pre-select the current working directory, run

dconf write /org/gtk/settings/file-chooser/startup-mode \"cwd\"

or use a GUI program like dconf-editor.

share|improve this answer
Well indeed it does disable the Recent item (upvoting...) but no item is pre-selected, which still feels a bit strange and is cumbersome to use with keyboard only. Maybe there's similar item as StartupMode=recent in GTK2...? – Alois Mahdal Apr 13 '15 at 19:10
I've managed to figure that out as well; I've updated my answer accordingly. – mic_e Apr 14 '15 at 0:32
Sounded promising, but unfortunately, doesn't do the trick for me. – Thomas W. Jan 30 at 14:11

Actually you can disable it: open or create ~/.config/gtk-2.0/gtkfilechooser.ini and add these lines to it:

[Filechooser Settings]

Replace cwd with last if you prefer to start with last selected folder instead.

I think this hidden option should also work for gtk3, but I did not test it.

share|improve this answer
Sorry, but did not work for me--still Recently Used is offered and pre-selected. I tried even logging in/out and using mousepad, which depends on libgtk2.0-0. – Alois Mahdal May 9 '13 at 9:46
It worked for me, but I had to change the variable StartupMode from recent to cwd in the same file. – jeremija Oct 23 '13 at 17:00
@jeremija - could you please post the config that works? What exactly do I have to add? – Martin Vegter Jun 1 '14 at 21:54
@MartinVegter see the answer I just posted – jeremija Jun 2 '14 at 6:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.