Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a trouble with usb WiFi dongle TPLink WN725N (rtl8192cu driver). Dongle it start, but cannot connect. Driver in official Realtek site support only 2.6.18~2.6.38 and 3.0.8 kernels. Is there a way to run it on kernel 3.8? (sorry for my english)

dmesg show this error:

IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
share|improve this question
    
I have that dongle and the stock 8192cu driver works for me. Have you tried initializing and configuring it manually? –  TAFKA 'goldilocks' Apr 26 '13 at 19:11
    
This driver requires a firmware blob that some distros ship in a package separate from the kernel. What distro are you using? –  bahamat Jun 17 '13 at 7:22
    
@bahamat, Fedora 18. Tried on other, to example Ubuntu 12.04. –  maximkou Jun 17 '13 at 7:28
add comment

1 Answer

You do not need to the driver from realtek. I was able to use the mainlined rtl8192cu driver on Linux 3.9.1. Looking at the git log, I see that it was already available since linux-2.6.39.y (git branch --contains 663dcc73675bd70ee11195ce832b1d1691f967d0).

CONFIG_RTL8192CU must be enabled when building the kernel. Note that CONFIG_EXPERIMENTAL needs to be enabled in kernels before 3.6. The resulting module will be called rtl8192cu.

share|improve this answer
    
Thanks for the answer. I tried this variant before, but the result is the same. –  maximkou Jun 17 '13 at 7:27
    
I bought the WN725N v1 which has the rtl8192cu chip. Using the mainlined driver of 3.9(.1 or -rc?) showed issues like packet loss. The driver provided by realtek did not have such issues. Now, are you aware that a second version of the TP-LINK WN725N exist? That one uses a different driver, the 8188eu. –  Lekensteyn Jun 17 '13 at 8:21
    
Yes, of course. This driver is used by default after installation. But it also does not connect to the network. Thanks for trying to help. I'm tired of the second month to suffer and I bought today a normal adapter. –  maximkou Jun 17 '13 at 11:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.