Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

A few days ago, I managed to get my wireless network working on ArchLinux.

My network card is:

~/ lspci | grep Network
03:00.0 Network controller: Broadcom Corporation BCM4321 802.11a/b/g/n (rev 03)

systemd-analyze show me that some service takes about 30 seconds:

~/ systemd-analyze blame
         31.543s NetworkManager-wait-online.service
           850ms NetworkManager.service
           166ms systemd-udev-trigger.service
           153ms alsa-restore.service
           151ms systemd-logind.service
           147ms systemd-fsck@dev-sdb1.service
           147ms var.mount
           113ms systemd-tmpfiles-setup.service
           113ms systemd-sysctl.service
           102ms home.mount
           100ms systemd-fsck@dev-sdb3.service
           100ms dev-hugepages.mount
            99ms systemd-random-seed-load.service
            98ms systemd-vconsole-setup.service
            96ms systemd-modules-load.service
            92ms dev-mqueue.mount
            90ms sys-kernel-debug.mount
            67ms tmp.mount
            65ms systemd-remount-fs.service
            65ms polkit.service
            50ms systemd-udevd.service
            50ms udisks2.service
            43ms sys-kernel-config.mount
            25ms rtkit-daemon.service
            24ms wpa_supplicant.service
            16ms systemd-journal-flush.service
            13ms systemd-user-sessions.service
            12ms upower.service
            11ms dev-sdb2.swap

If I disable the 30-seconds service, I still have the same problem. And lshw -C network shows:

~/ lshw -C network
  *-network               
       description: Ethernet interface
       produit: MCP65 Ethernet
       fabriquant: NVIDIA Corporation
       identifiant matériel: 6
       information bus: pci@0000:00:06.0
       nom logique: enp0s6
       version: a3
       numéro de série: 0a:f1:56:59:50:d4
       capacité: 1Gbit/s
       bits: 32 bits
       horloge: 66MHz
       fonctionnalités: bus_master cap_list ethernet physical mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=forcedeth driverversion=0.64 latency=0 link=no maxlatency=20 mingnt=1 multicast=yes port=MII
       ressources: irq:20 mémoire:f2487000-f2487fff portE/S:30e0(taille=8)
  *-network
       description: Network controller
       produit: BCM4321 802.11a/b/g/n
       fabriquant: Broadcom Corporation
       identifiant matériel: 0
       information bus: pci@0000:03:00.0
       version: 03
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: bus_master cap_list
       configuration: driver=b43-pci-bridge latency=0
       ressources: irq:16 mémoire:f2000000-f2003fff mémoire:f2500000-f25fffff
  *-network
       description: Interface réseau sans fil
       identifiant matériel: 1
       nom logique: wlan0
       numéro de série: 00:1a:73:e7:45:69
       fonctionnalités: ethernet physical wireless
       configuration: broadcast=yes driver=b43 driverversion=3.8.7-1-ARCH firmware=666.2 ip=192.168.1.119 link=yes multicast=yes wireless=IEEE 802.11bg

The only difference in the latest command before I get connected is that the last *-network got the configuration

link=no

instead of:

link=yes

Do you know how I can get my wireless network to start instantly instead of waiting 30 seconds?

share|improve this question
    
I have the same Network controller. I used this netcfg guide to automatically connecting to my wireless network. Look under 'Automatic Operation'. –  Rany Albeg Wein Apr 26 '13 at 3:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.