Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I just installed 32-bit Ubuntu Maverick 10 Stable everything is working fine, The system spec's are as below:

3 Ghz Intel DG101 512 MB RAM 80 GB HDD 256 MB Ati Radeon Xpress

the only problem is when the Youtube videos are maximized they consume allot of CPU plus video bacomes slower and choppy..... What to do? I have FireFox and installed the FlashPlayer 10 also. But no luck...Any Ideas how to fix? The videos work absolutely good in XP in same computer..... I have tried Google Chrome also but no luck in that also.... Any answer 'll be appreciated.

share|improve this question
    
Recommend you ask this on askubuntu.com –  Paul Dixon Feb 13 '11 at 10:30
1  
The problem is your graphics driver. You'll have to install the vendor specific driver. –  Yngve Sneen Lindal Feb 13 '11 at 10:32
    
Nopes its not the driver issue, i have compiz installed and it works perfectly alright! Every effect of compiz enabled and it works very very nice.... Its something other. –  Ahsan Feb 13 '11 at 11:40
    
I have just tried opera , it does some better then those of Firefox and Chrome but its choppy too... By the way is there anyway i can get Drivers for ATI Radeon 200 Xpress ? for Ubuntu Maverick! –  Ahsan Feb 13 '11 at 11:44
    
@Paul Dixon: there's no reason this can't be answered here, as it is not particularly Ubuntu-specific. –  mattdm Mar 13 '11 at 2:34
add comment

migrated from stackoverflow.com Feb 13 '11 at 11:44

This question came from our site for professional and enthusiast programmers.

3 Answers

To find proprietary driver for ATI card head to the ATI download page and check if a Linux driver is available for your model. Alternatively, you can use Ubuntu's driver finder by going to System -> Administration -> Hardware Drivers.

If installing the driver doesn't help try the newest version of Flash by getting it from Adobe.

share|improve this answer
1  
Finally i made it, all you have to do is to open youtube video any video then right click on video and choose Settings, then a dialogue box will appear, uncheck the "Enable Hardware Acceleration" from that box, reload the video and enjoy!! [SOLVED] –  Ahsan Feb 16 '11 at 8:51
1  
@Ahsan So you should delete the comment and post it as an answer. You are sure to get my vote :) –  phunehehe Feb 16 '11 at 8:59
    
thanks phunehehe –  Ahsan Apr 16 '11 at 13:52
add comment

He he... You guys are funny . . It s very simple. It will work in 320p when the screen is maximised. Change it from 480p to 320p which is near the volume control when the screen is maximised. All the best watching Youtube!!

Regards, Aravindh :)

share|improve this answer
add comment

Finally i made it, all you have to do is to open youtube video any video then right click on video and choose Settings, then a dialogue box will appear, uncheck the "Enable Hardware Acceleration" from that box, reload the video and enjoy!! [SOLVED]

share|improve this answer
    
This is not really the solution, only a hack that makes it not so symptomatic. The correct answer here was given in comments and by @phunehehe as an answer. You don't just need a working graphics driver, you need the latest proprietary ones and the latest flash player. Flash's hardware acceleration is way picker than compiz, it only cooperates with a few versions of a few proprietary drivers. –  Caleb Apr 16 '11 at 14:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.