Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm setting up an arch linux system(latest version) on my laptop. It already boots and configuration for network it's done via systemctl. Following instructions on the wiki I configured the ethernet service, first finding the service name with ip link, and then setting it up with sudo systemctl enable dhcpcd@<servicename>.service. But on reboot the name of the network device changed to eth0, so my configuration doesn't work.

Running

$ sudo systemctl disable dhcpcd@<old service>.service

(and all other systemctl commands aside list-units )throws error:

[...] Failed to create mount unit file /run/systemd/generator/-.mount, as it already exists. Duplicate entry in /etc/fstab?

How can I remove/disable the old config and set it up again?

Note: oddly my prompt changed to [<username>@dhcppc0]

share|improve this question
    
Throws what error? –  warl0ck Apr 22 '13 at 1:58
    
Do you have an /etc/udev/rules.d/80-net-name-slot.rules? –  jasonwryan Apr 22 '13 at 2:00
    
@jasonwryan Nope, directory is empty. –  nicooga Apr 22 '13 at 2:08
add comment

1 Answer

Sometimes there was bug in the dhcpcd service, so it could work if you just do systemctl enable dhcpcd.service.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.