Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I recently replaced a disk containing my /home partition only. Upon attempting to upgrade my kernal package (Debian Squeeze) I get the following error:

/usr/sbin/grub-probe: error: Couldn't find PV pv1. Check your device.map.

Google searching suggested this solution:

root@debian1:~# mv /boot/grub/device.map /boot/grub/device.map_orig
root@debian1:~# grub-mkdevicemap
root@debian1:~# update-grub

The first two commands succeed without error, yet the third command update-grub fails with the same error mentioned above.

I've checked my /boot/grub/device.map file, and it seems to match the ids listed when I run ls -l /dev/disk/by-id/.

Any idea how to resolve this?

share|improve this question
    
What does pvdisplay show? My guess is that you were using LVM on the old drive and yanked it out without telling LVM to remove it, so now it's still looking for that disk. –  psusi Apr 20 '13 at 19:31
add comment

1 Answer

@psusi: You're an extremely good guesser. As you mentioned, I didn't update the LVM file when replacing the disk.

vgreduce volume_group_name --removemissing fixed the issue.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.