Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Some days ago my evince stopped printing. After reinstalling it and trying different versions without success I figured out that it works from other user accounts on the same box.

So which files stores evince and cups per user basis such that I can remove or modify some files for the user where evince makes problems?

Edit #1

Printing from all other applications works. Evince from the particular user account just feeds out empty pages.

Edit #2

The user accounts where it worked didn't have any ./config/evince/ and ./cups. I just deleted those directories in the account where it doesn't work, but it doesn't help.

Any ideas what may be different between the users regarding evince printing?

share|improve this question
Can you print this particular PDF file from something other than evince? I'd try xpdf for example. Trying to narrow down the issue further. Also what version of evince are you using? Found this bug in launchpad: bugs.launchpad.net/ubuntu/+source/evince/+bug/850195 – slm Apr 21 '13 at 12:24
There is also this bug in launchpad: bugs.launchpad.net/ubuntu/+source/evince/+bug/186655 – slm Apr 21 '13 at 12:30
Found this issue being referenced on askubuntu as well, askubuntu.com/questions/265097/…. Given this was working for you and now not, did you happen to apply some updates to your system recently? – slm Apr 21 '13 at 12:48
@don_crissti Yes it happens with all pdf I tried. Print preview works. If I start evince from terminal and print a pdf I don't get any output in the terminal. – student Jun 9 '13 at 17:50
Can you try the steps in section #3 of my answer and let us know if they fixed your issue? – slm Jun 10 '13 at 2:29
up vote 4 down vote accepted

You don't say in your question but are you able to print using other applications? The command line? I'd confirm that you're printer is still configured and working correctly by doing the following:

1. confirm that printer is setup and accessible using:


# check for jobs on the default printer
% lpq
mfc-8480dn is ready
no entries

# check for any jobs on all printers
% lpq -a
no entries

lpinfo -v

% sudo lpinfo -v
network beh
direct scsi
network socket
serial serial:/dev/ttyS0?baud=115200
network http
network ipp
network https
network lpd
network dnssd://Canon%20S820%20%40%20scully._ipp._tcp.local/cups
direct hp
network smb
direct hpfax
network lpd://mfc-8480dn.bubba.net/BINARY_P1

test print from command-line

lpr somefile.txt

Try using the Troubleshooting Wizard

There is a troubleshooting wizard in system-config-printer (System -> Administration -> Printing in GNOME classic, Gear icon at the upper right of the screen -> Printers in Unity). You find it in the "Help" menu of system-config-printer. It produces a text file with a lot of useful information to attach to bug reports. Follow the instructions of the wizard. If you reach the test page step, you can either click the button to print the test page or you can print a job to the selected printer from any application or from the command line. The job will be shown in the integrated job viewer. Wait until it completes or goes into "Stopped" state. ONLY THEN AND NOT BEFORE mark the checkbox at the job, answer whether the job got printed correctly, and click "Forward". After that the file will get generated. Save it and attach it to your bug report.

           ss of printer troubleshooting

Further details are available in the Ubuntu Debugging Printing Problems Wiki Topic.

2. Issues with Ubuntu and Evince printing blank pages

During researching this issue I did come across a lot of people having issues with printing and blank pages on various versions of Ubuntu.

There was a somewhat involved fix that I found here, Fixing PDF printing problems on Ubuntu 12.04. In the comments the fix mentioned fixed the issue for some but not all of the commenters.

3. The directory: $HOME/.gnome2/evince

You might try either deleting the print-settings file under $HOME/.gnome2/evince or even just deleting that directory entirely.

$ rm -fr $HOME/.gnome2/evince
share|improve this answer
The OP wrote 'Printing from all other applications works. Evince from the particular user account just feeds out empty pages.', so it looks like he has not problem with reaching the printer. – Anthon Apr 21 '13 at 8:48
@Anthon, thanks I saw he edited his question. – slm Apr 21 '13 at 12:21
@student - see my updates, section #3 in my answer. – slm Jun 9 '13 at 20:17
AWESOME! That was an annoying issue, glad we figured it out! Can you please mark my answer as accepted so that other ppl know it's been resolved? Thanks. – slm Jun 10 '13 at 13:43

You should compare the following file between your account and an account for which printing works:


(and/or backup your copy and replace with one from another user). If that doesn't help you might try to replace the whole ~/.config/evince directory.

share|improve this answer
Thanks, but it doesn't help. – student Apr 20 '13 at 16:22
I realised that was evince only. The cups options are in ~/.cups/lptoptions can you compare those as well? – Anthon Apr 21 '13 at 8:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.