Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Problem

  • Not able to connect to wireless network even after giving the correct password

Characteristics of Problem

  • After starting laptop, I choose the wireless network from the network manager icon on taskbar.
  • I am asked for password
  • I enter the correct password
  • After a minute I get dialog box asking me to enter password again
  • If I enter correct password, I get the same dialog box after a minute asking me to enter password again.
  • I updated the router firmware and tried again and the same sequence of events happens.

System Properties

  • Using WPA2 security on the router
  • Router model is netgear WGT624 v4
  • Updated the firmware to the latest
  • Using Bodhi Linux 2.3
  • lspci gives the line 03:00.0 Network controller: Atheros Communications Inc. AR9462 Wireless Network Adapter (rev 01)
  • nm-tool gives the driver name as ath9k
  • Output on dmesg

wlan0: authenticate with 00:1e:2a:5f:14:48
wlan0: capabilities/regulatory prevented using AP HT/VHT configuration, downgraded
wlan0: send auth to 00:1e:2a:5f:14:48 (try 1/3)
wlan0: authenticated
wlan0: associate with 00:1e:2a:5f:14:48 (try 1/3)
wlan0: RX AssocResp from 00:1e:2a:5f:14:48 (capab=0x431 status=0 aid=6)
wlan0: associated
cfg80211: Calling CRDA for country: US
ath: regdomain 0x8348 updated by CountryIE
ath: EEPROM regdomain: 0x8348
ath: EEPROM indicates we should expect a country code
ath: doing EEPROM country->regdmn map search
ath: country maps to regdmn code: 0x3a
ath: Country alpha2 being used: US
ath: Regpair used: 0x3a
cfg80211: Regulatory domain changed to country: US
cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
cfg80211: (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211: (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211: (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
wlan0: Limiting TX power to 27 (27 - 0) dBm as advertised by 00:1e:2a:5f:14:48
wlan0: deauthenticating from 00:1e:2a:5f:14:48 by local choice (reason=3)
cfg80211: Calling CRDA to update world regulatory domain
cfg80211: World regulatory domain updated:
cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211: (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)

Could someone please tell me if how I may get my comp to connect to the network?

share|improve this question
    
Have you tried with a different device as client and does that connect? –  Anthon Apr 19 '13 at 6:49
    
There are 3 other people using the same router through wifi and its working fine for them. So yes, it does connect with a different device as client. The problem seems to be from my system.. –  Jay Apr 19 '13 at 9:02
1  
Google deauthenticating from by local choice (reason=3) gives several possible solutions, I would start trying those if you haven't already. –  Anthon Apr 19 '13 at 9:30
    
Thanks for the pointer. I saw that in the output of dmesg but didn't think it could turn out any useful results. –  Jay Apr 19 '13 at 16:28
1  
Actually there were some references to 'downgrading initscripts' and 'double network managers enabled' so I thought something like that might be the problem. Yes 'close' –  Anthon Apr 19 '13 at 16:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.