Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm unable to resume from 'Suspend to RAM'. It resumes properly, albeit with a very very dim screen (so dim I can barely make out the desktop). Trying to brighten the screen using the Fn keys doesn't work, and the only option is to switch the machine off and on.

I'm running Bodhi Linux 2.3 with onboard Intel graphics. I think the driver being used is i915, according to lsmod, but I could be wrong.

Output of uname -a and lsb-release -a:

Linux bodhiman 3.8.0-12-generic #21 SMP Tue Mar 12 17:39:30 CDT 2013 x86_64 86_64 x86_64 GNU/Linux

Distributor ID: Ubuntu
Description: Bodhi 2.3.0
Release: 12.04
Codename: precise

What can I do to diagnose this and fix it?

share|improve this question
    
Kernel version? There have been some issues with the more recent kernels and the backlight being set to zero on resume; not your issue, but possibly related. –  jasonwryan Apr 18 '13 at 21:38
    
Hello jasonwryan. I have updated the question to include that information. –  Jay Apr 18 '13 at 21:48
    
You could try appending acpi_osi='!Windows 2012' acpi_backlight=vendor splash to your kernel line... –  jasonwryan Apr 19 '13 at 0:28
    
I tried that and it did not work I'm afraid. There must be another way.. –  Jay Apr 19 '13 at 6:40
add comment

2 Answers

I think I solved the problem.

@drs proposed I install xbacklight to make it work but after installing it, I kept getting an error message saying "No outputs have backlight property"

A little bit of googling the error led me to 2 files in the /sys/class/backlight directory. The 2 files were

/sys/class/backlight/acpi_video0 /sys/class/backlight/intel_backlight

I tried,

echo 5 | /sys/class/backlight/acpi_video0/brightness and nothing changed

And then I tried,

echo 5 | /sys/class/backlight/intel_backlight/brightness and the screen went dark

So now I knew that I had to use the vendor driver (in this case intel) to change the brightness of the screen.

I opened /etc/default/grub and changed the line

GRUB_CMDLINE_LINUX_DEFAULT="splash quiet"

to

GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=Linux acpi_backlight=vendor splash quiet"

and then I ran the command

sudo grub-mkconfig -o /boot/grub/grub.cfg

and restarted the system.

Now my function keys to change the brightness are working and when I resume from 'suspend to RAM' it still resumes blank but now I can press the brightness keys just once to bring it back to pre-suspended brightness levels.

share|improve this answer
    
It's a minor detail, but are you sure that was echo 5 | ... and not echo 5 > ...? My /sys/class/backlight is empty, but I find it hard to believe that those files would be executables, plus the normal approach is to write something to the kernel control files in /proc and /sys to change a setting. –  Michael Kjörling May 20 '13 at 7:33
    
I don't have linux box with me right now otherwise I would test it. But I believe you are right. Although I think "echo 5 |" works as well, even though it is slightly unconventional I guess. –  Jay May 22 '13 at 3:10
add comment

You can use xbacklight to set the brightness of your screen from and you can place scripts in /etc/pm/sleep.d/ so that they are executed when resuming. Try creating this in /etc/pm/sleep.d/99-set-backlight.sh

#!/bin/sh
case "$1" in 

    resume|thaw)

        export DISPLAY=:0
        xbacklight -set 60
esac

Make sure you have xbacklight installed and choose a comfortable brightness percentage for your screen.

share|improve this answer
    
xbacklight quits with "No outputs have backlight property". But googling the error led me to a solution. : ) Thank you. –  Jay Apr 19 '13 at 17:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.