Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm running a tightvnc server on Ubuntu 11.04 with a Gnome fallback session. Things seem to work fine except that when I try launching an application that needs xfonts-100dpi. All application menus are shown as little boxes instead of characters. It's as if the fonts are missing. The strange thing is, xfonts-100dpi is already installed and the same application runs fine if I log in to the box directly. Can you please help?

My ~/.vnc/xstartup

unset SESSION_MANAGER
/usr/bin/gnome-session-fallback
share|improve this question

1 Answer 1

If you add in /etc/X11/xorg.conf

Section "Files"
FontPath        "/usr/share/fonts/X11/100dpi/:unscaled"
EndSection

Solve you problem?

share|improve this answer
    
I have already tried messing with the font path in the VNC server configuration. As suggested elsewhere on the Internet, I ran xset -q when physically logged in. From the resulting output, I took the FontPath and configured the vncserver Perl script to set the same FontPath. The fonts you're referring to were part of what I added to the path. It didn't help. –  Joseph R. Apr 18 '13 at 18:03
    
For the record, I tried your suggestion as well and no joy... –  Joseph R. Apr 25 '13 at 17:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.