Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Is there a way to selectively disable gvfsd-cdda on Debian Squeeze?

Since I updated my machine to Squeeze grip can no longer eject a CD, which interferes with ripping. I traced it back to gvfsd-cdda, but found no preference or configuration to disable it. I can't uninstall package gvfs-backends either, because it is required by gnome-core.

I did find /usr/share/mounts/cdda.mount, but disabling that feels like an ugly hack that will be overwritten on the next update of the package.

share|improve this question
If you use k3b, it should pop up the dialog with an option to kill the process. It's fine to do so because it'll start up next time you eject/load a cd to automount it. You can always just run pkill gvfsd-cdda manually. Or you could add a context menu option to the .desktop file for grip. An example of how to do this for k3b can be found here. You can adapt it by finding the appropriate grip.desktop file. – TrinitronX Dec 31 '14 at 9:57
find /usr/share/applications/ -iname '*grip*.desktop' should do it. – TrinitronX Dec 31 '14 at 9:58

I have no idea if there's a way to fix or cleanly disable gvfsd-cdda, but you can move it out of the way without running into trouble with the package manager.

Debian (and more generally any distribution using dpkg) has a generic mechanism for providing your own version of a file that's normally under the package manager's control. If you find you must change /usr/lib/gvfs/gvfsd-cdda or /usr/share/mounts/cdda.mount, use dpkg-divert so that the package's version will be diverted to a different file name:

dpkg-divert --add --local --rename --divert /usr/lib/gvfs/gvfsd-cdda.debian /usr/lib/gvfs/gvfsd-cdda
ln -s /bin/true /usr/lib/gvfs/gvfsd-cdda

or perhaps

dpkg-divert --add --local --rename --divert /usr/share/gvfs/mounts/cdda.mount.debian /usr/share/gvfs/mounts/cdda.mount
share|improve this answer
This doesn't work real well, though, as you'll get a dialog box after about 5 minutes from dbus complaining that "gvfsd-cdda didn't respond". Less annoying than having sound-juicer leap up in your face every time, but still a pain. – womble Mar 21 '11 at 6:36
@womble: Did you try just doing the first step (diverting gvfsd-cdda) and not the second, and then perhaps restarting dbus? Or diverting /usr/share/gvfs/mounts/cdda.mount instead (and perhaps restarting Gnome)? – Gilles Mar 21 '11 at 7:55
It's your answer, not mine. Just saying that your answer, as written, isn't a good solution. – womble Mar 23 '11 at 8:46

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.