Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

This is a weird one... I recently upgraded from Debian lenny to squeeze (following the upgrade instructions step by step). Everything went surprisingly well, except for one piece of strange new behavior I haven't encountered before. First, the left arrow key won't work at all (although right, up, and down do). Second, if I keep the left arrow key held down for a few seconds and then release it, I get trapped in Mode_switch mode. In other words, I have a .Xmodmap file with the following:

keycode 113 = Mode_switch
keycode 38 = a A aacute Aacute
keycode 26 = e E eacute Eacute
...

After I've held down the left arrow key for a few seconds, every a or e character I type is accented, and the only way I can revert this is to log out and log back in to my Gnome session.

I know something keyboard-related changed from lenny to squeeze, but I don't know how to troubleshoot something like this. Any ideas what's wrong?

share|improve this question
1  
Do you have the same problem without your .Xmodmap file? Do you have the same problem in another window manager or desktop environment (try something like startx fvwm -- :1 from a text console (Ctrl+Alt+F1))? –  Gilles Feb 12 '11 at 22:04

1 Answer 1

up vote 1 down vote accepted

After looking further, I found that the keycode set as Mode_switch actually didn't correspond to my Alt_R key as I intended (I changed keyboards a while ago, but didn't notice this until the upgrade). Setting the keycode to the correct key fixed the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.