Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

This is either a basic unix problem or one specific to ejabberd - I don't know enough to know which it is.

So I've installed ejabberd XMPP server using an OSX installer version 2.1.11 -- 'ejabberd-2.1.11-osx-installer'.

Works fine in base mode. However, I want to add a message archiving module -- mod_archive_odbc. Per instructions on a tutorial, I've copied the four mod_archive .beam files (compiled erlang files) into: ejabberd/lib/ejabberd-2.1.11/ebin/.

I've also modified the modules section of ejabberd.cfg to include mod_archive:

 {mod_archive_odbc, [{database_type, "mysql"},
                      {default_auto_save, true},
                      {enforce_default_auto_save, false},
                      {default_expire, infinity},
                      {enforce_min_expire, 0},
                      {enforce_max_expire, infinity},
                      {replication_expire, 31536000},
                      {session_duration, 1800},
                      {wipeout_interval, 86400}]},

When I start ejabberd by typing ./start in the shell I get the following in my erl_crash_dump:

Slogan: Problem starting the module mod_archive_odbc for host "localhost" 
 options: [{database_type,"mysql"},

Now, I'm thinking this could be because I just copied the .beam files for mod_archive after running the binary installer and so they're not compiled in. Is my line of thinking correct? If yes, then the issue would be to recompile with those added .beam files but is that even possible when installing with the binary installation?

I tried using the the source code to build ejabberd but was having problems just getting the base version working. The error I got when building from source was:

Slogan: Kernel pid terminated (application_controller) ({application_start_failure,kernel,{shutdown,{kernel,start,[normal,[]]}}})

If I there isn't a way to add mod_archive to the binary installation I'll try figuring out why my source build isn't working, but it seems like I'm closer with the binary install at the moment.

share|improve this question
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.