Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How come this happens?:

stan@tcpc:~/.ssh$ ssh-add -l
8192 e0:45:5e:cc:45:3e:17:2b:a6:54:6f:8d:53:1b:j2:e3 github (RSA)
2048 25:41:53:a6:45:5d:ac:eb:5c:45:f8:ce:42:a9:he:aa BITBUCKET (RSA)
stan@tcpc:~/.ssh$ ssh-add -D
All identities removed.
stan@tcpc:~/.ssh$ ssh-add -l
8192 e0:45:5e:cc:45:3e:17:2b:a6:54:6f:8d:53:1b:j2:e3 github (RSA)
2048 25:41:53:a6:45:5d:ac:eb:5c:45:f8:ce:42:a9:he:aa BITBUCKET (RSA)

How come keys aren't being erased?

p.s. could be this bug? http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=472477 I'm on arch linux though...

share|improve this question
    
That bug is years old; on an up-to-date Arch box, it works as expected: openssh 6.2p1-1 – jasonwryan Apr 16 '13 at 18:16
    
jsonwryan... it's actual not years old. Last comment dated 05 Oct 2012 - mentions that it still wasn't fixed. Other comments suggest that the problem is upstream. And no - it doesn't work for me on up-to-date Arch system. However - when I move ssh keys from ~/.ssh directory into ~/.ssh/my_keys (as suggested in bug report) -> addition and removal does work as expected. – agent_smith Apr 16 '13 at 18:25
3  
Read the report carefully: "Fixed in version 3.2.2-2" - pacman -Ss gnome-keyring: 3.6.3-1 – jasonwryan Apr 16 '13 at 18:32

The steps in this post worked for me; you just need to open the Startup Applications manager, uncheck the entry for "SSH Key Agent - GNOME Keyring: SSH Agent", and restart Unity. If it doesn't show up, edit /etc/xdg/autostart/gnome-keyring-ssh.desktop and change NoDisplay=true to NoDisplay=false.

share|improve this answer

Go to /tmp folder, delete all folder starts with ssh

solomon@debian:/tmp$ rm -rf ssh

solomon@debian:/tmp$ ssh-add -D

All identities removed.

solomon@debian:/tmp$ ssh-add -l
The agent has no identities.
share|improve this answer
    
Don't know why this was down voted. It put me in the right track, although I wouldn't remove ssh folder (!!!!). By just changing folder name and then back to .ssh, gnome keyring stopped listing ssh key. That allowed me to do ssh-add and it all was working as it should – cortopy May 15 at 16:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.