Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've been having a problem all day. It all started when I tried to partition my HD to install Ubuntu with bootcamp on my mac. The install froze and when I restarted the Apple logo was replaced with a "do not enter" sign (circle with slash). I've been searching forums for a solution and even tried to run a LiveCD but that failed. I think I need to remove GRUB from my MBR. Anyone have some suggestions/help? Much appreciated.

share|improve this question
1  
you could also boot ubuntu again and restore GRUB –  starcorn Feb 11 '11 at 23:28
    
Restore the apple bootloader/MBR record from the OSX disk. It sounds like something got into conflict between GRUB and Apple's boot loader. Once you rewrite the MBR with Apple's bootloader, grub should disappear. –  FloppyDisk Mar 20 '12 at 11:22

1 Answer 1

Did you try booting from an OSX boot disc? Then as it wants to start (re)installing OSX, just stop and go into disk utilities to see if you can restore your OSX partition as the boot partition. I suppose the Live CD you are referring to is an Ubuntu 10.04 cd, right?

Tell me what you've tried already

Did you figure it out on your own ? If so,could you perhaps tell us how you did proceed ?

share|improve this answer
    
Really Kevin ? taking time to put caps on my answer ? :) –  marc-andre benoit Mar 6 '12 at 14:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.