Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm using Arch Linux x86_64 with Gnome and PulseAudio. I have USB speakers, which work for the sounds in system menus and most other applications. But whenever I play Flash videos, they output their sound through the onboard sound card (which usually isn't hooked up to anything). This happens in both Firefox and Chromium. I can't find anything that would let me redirect Flash's audio output to my USB speakers.

The following relevant packages are installed:

gnome-media-pulse
gnome-settings-daemon-pulse
libcanberra-pulse
pavucontrol
pulseaudio
pulseaudio-alsa
lib32-libcanberra-pulse
lib32-libpulse
flashplugin
share|improve this question
    
This might be related. Have you tried it? It would be an "official" solution. –  user9590 Aug 4 '11 at 9:30

2 Answers 2

up vote 5 down vote accepted

The solution I found was to install the libflashsupport-pulse package from AUR and restart my computer.

share|improve this answer
1  
Interesting. Do you know what this package actually does? I'm on slackware, and I can't think of why any glue would be required. Glad you got it working! –  gamen Feb 13 '11 at 15:56
    
@gamen Apparently Flash is hardcoded to look for certain versions of certain library files. I think what this package does is install a library file that effectively redirects Flash output to pulse. –  extropic-engine Feb 13 '11 at 17:51

To begin with, one very good source for information on pulseaudio problems is the perfect setup page.

I wonder, do all ALSA applications have this problem? For example, if you force, say mplayer to use alsa ("mplayer -ao alsa ...") does that go to your USB speakers?

An other perhaps more direct reason for this could be that your flash plugin isn't configured properly. You do this by surfing to the settings manager (that link actually leads to it immediately; it's not a screenshot or tutorial); see if the speaker output is configured correctly.

share|improve this answer
    
The perfect setup page had some guidelines on how to set pulse as the default in /etc/asound.conf but Arch had already set those up for me. I tested other ALSA applications and they all output to the correct source. I looked at the settings manager, but I didn't see anything about speaker outputs. –  extropic-engine Feb 12 '11 at 17:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.