Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have this Toshiba laptop I started poking around trying to find out why it quits out so often and is just so bad. This guy seems to have the same problem with the fact that it works perfect in Windows and it cuts out so much. It's quite annoying. Anyone know of any solutions?

Edit* I found that I have to constantly "forget" the network to then re connect to it. This kind of fixes the problem but then of course it derps out again.

share|improve this question
    
Can you provide some info about your wireless card and version of Fedora? I looked at the link but it's very vague on the details of which chipset the wireless is using. Some dmesg output would suffice. I know lots people with Mac's, Win7, and Linux and various hardware that have issues with wireless-N. This can be disabled. –  slm Apr 14 '13 at 23:18
    
@slm Fedora 18 and I posted a link because I couldn't find anything better either. Output is here freetexthost.com/n6w1v3c10y –  Griffin Apr 15 '13 at 0:09
    
From the link in the comment (it would have been better if you added it to the question) is looks like the router is on a channel that is forbidden for use in the US. Try changing that one. –  vonbrand Apr 15 '13 at 0:37
    
Two most common reasons I've met are powersaving issues (bad settings) and temperature. In second case something might be shown in dmesg logs. My own wireless card in my laptop restarts itself when temperature on it's sensor rises above 60; that was giving me quite a hard time. –  TNW Apr 15 '13 at 1:05
    
Thanks for the logs. One thing you might want to try: " modprobe iwlagn 11n_disable=1". This will disable wireless-N. You can read more about it in my blog post: lamolabs.org/blog/6049/…. Also can you provide dmesg logs for when the wireless NIC drops out? –  slm Apr 15 '13 at 1:28
show 1 more comment

1 Answer

That might be a problem with WiFi, not Fedora at all. Check the following:

  • Any other WiFi routers around? Check the output of iwlist wlan0 scan (assuming your card is wlan0), see if your router is using a crowded channel. If so, look for an unused one (or one with less/worse signal ones) and reconfigure the router
  • See if it depends on the position of the machine. Metal does shield the WiFi signal, other materials can absorb the signal; might need to move the router around. Perhaps its antennas aren't in the best position?
  • Is there any possible source of electromagnetic interference? Bad fluorescent lighting, perhaps?
share|improve this answer
    
My closest neighbor is corn.... The other points should be as self explanatory. –  Griffin Apr 15 '13 at 0:33
    
Also tested it in multiple other buildings where I am sitting directly under the router. –  Griffin Apr 15 '13 at 15:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.