Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to install a perl package and getting the following dependencies error:

[user@localhost Downloads]$ rpm -Uvh ImageMagick-6.8.4-9.i386.rpm 
error: Failed dependencies:
    libltdl.so.3 is needed by ImageMagick-6.8.4-4.i386

In order to solve it, I have tried to install the missing package but it seems that it already exists:

[Evgeny@localhost Downloads]$ sudo yum install libltdl.so.3
...
No package libltdl.so.3 available.

Then I have tried to use yum with reinstall option but I got another error:

[Evgeny@localhost Downloads]$ sudo yum reinstall libltdl.so.3
...
No Match for argument: libltdl.so.3
Error: Nothing to do

What's the problem here? Should I completely uninstall current libltdl.so.3 package and the install it form scratch? Or maybe there is a different issue?

share|improve this question
    
libltdl.so.3 is the name of the file you're wanting to get. You have to give yum package names to install to figure out what package provides a particular file:"yum whatprovides */libltdl.so.3" –  Bratchley Apr 14 '13 at 19:01

3 Answers 3

you need to install the package "libtool-ltdl" not "libltdl.so.3" This is only a shared library that is a part of the package mentioned above.

yum install "libtool-ltdl"
rpm -Uvh ImageMagick-6.8.4-9.i386.rpm

should get it working.

here are all of the results for packages that contain the file libltdl.so.3 for centos

You have chosen search in content of rpms.
Display 1 - 38 hits of 38. Search took 0.02 seconds.
1
1




Search results for libltdl.so.3 :
CentOS 5    ftp.centos.org/5.9/os/x86_64/CentOS/libtool-ltdl-1.5.22-7.el5_4.x86_64.rpm
CentOS 5    ftp.centos.org/5.9/os/x86_64/CentOS/libtool-ltdl-1.5.22-7.el5_4.i386.rpm
CentOS 5    ftp.centos.org/5.9/os/i386/CentOS/libtool-ltdl-1.5.22-7.el5_4.i386.rpm
CentOS Other    yum.trixbox.org/centos/4/RPMS/libtool-libs-1.5.6-4.EL4.1.c4.4.i386.rpm
Other   ftp.rpmhelp.net/pub/releases/1.0-CURRENT/i586/RPMS/libltdl3-1.4.3-9sls.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/g/gw/gwmos/GW Monitor Community Edition/5.0.5-208/groundwork-monitor-os-5.0.5-208.sles9.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/g/gw/gwmos/GW Monitor Community Edition/5.0.5-208/groundwork-monitor-os-5.0.5-208.sles10.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/g/gw/gwmos/OldFiles/groundwork-monitor-os-4.5-M1.31a.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/m/ma/mapifier/OldFiles/groundwork-monitor-os-4.5-M1.31.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/g/gw/gwmos/GW Monitor Community Edition/4.5.11/groundwork-monitor-os-4.5-11.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/a/ar/arp2.berlios/gg-libtool-1.4.2-2.i386.rpm
Other   ftp.sourceforge.net/pub/sourceforge/a/ar/arp2.berlios/gg-libtool-1.4.2-1.i386.rpm
Other   ftp.sourceforge.net/pub/sourceforge/a/ac/ac-archive/autotools/2002-03/autotools-for-ac.2.53.lt.1.4.2.am.1.6-2sfnet.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/a/ac/ac-archive/autotools/2002-03/autotools-for-ac.2.53.lt.1.4.2.am.1.5-2sfnet.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/a/ac/ac-archive/autotools/2002-03/autotools-for-ac.2.52.lt.1.4.am.1.4.5-2sfnet.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/a/ac/ac-archive/autotools/2002-03/autotools-for-ac.2.52.lt.1.4.am.1.4-2sfnet.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/a/ac/ac-archive/autotools/2002-03/autotools-for-ac.2.52.lt.1.4.2.am.1.6-2sfnet.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/a/ac/ac-archive/autotools/2002-03/autotools-for-ac.2.52.lt.1.4.2.am.1.5-2sfnet.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/a/ac/ac-archive/autotools/2002-03/autotools-for-ac.2.52.lt.1.4.2.am.1.4.5-2sfnet.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/a/ac/ac-archive/autotools/2002-03/autotools-for-ac.2.52.lt.1.4.2.am.1.4-2sfnet.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/a/ac/ac-archive/autotools/2002-03/autotools-for-ac.2.13.lt.1.4.am.1.5-2sfnet.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/a/ac/ac-archive/autotools/2002-03/autotools-for-ac.2.13.lt.1.4.am.1.4-2sfnet.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/a/ac/ac-archive/autotools/2002-03/autotools-for-ac.2.13.lt.1.4.2.am.1.5-2sfnet.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/a/ac/ac-archive/autotools/2002-03/autotools-for-ac.2.13.lt.1.4.2.am.1.4.5-2sfnet.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/a/ac/ac-archive/autotools/2002-03/autotools-for-ac.2.13.lt.1.4.2.am.1.4-2sfnet.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/a/ac/ac-archive/OldFiles/autotools-ac.2.52d.lt.1.4b.am.1.5-2sfnet.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/a/ac/ac-archive/OldFiles/autotools-ac.2.52d.lt.1.4.am.1.5-2sfnet.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/a/ac/ac-archive/OldFiles/autotools-ac.2.52d.lt.1.4.am.1.4.5-2sfnet.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/a/ac/ac-archive/OldFiles/autotools-ac.2.52d.lt.1.4.2.am.1.5-2sfnet.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/a/ac/ac-archive/OldFiles/autotools-ac.2.52d.lt.1.4.2.am.1.4l-2sfnet.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/a/ac/ac-archive/OldFiles/autotools-ac.2.52.lt.1.4b.am.1.5-2sfnet.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/a/ac/ac-archive/OldFiles/autotools-ac.2.52.lt.1.4.am.1.5-2sfnet.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/a/ac/ac-archive/OldFiles/autotools-ac.2.52.lt.1.4.am.1.4l-2sfnet.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/a/ac/ac-archive/OldFiles/autotools-ac.2.52.lt.1.4.am.1.4.5-2sfnet.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/a/ac/ac-archive/OldFiles/autotools-ac.2.52.lt.1.4.am.1.4-2sfnet.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/a/ac/ac-archive/OldFiles/autotools-ac.2.52.lt.1.4.2.am.1.5-2sfnet.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/a/ac/ac-archive/OldFiles/autotools-ac.2.52.lt.1.4.2.am.1.4f-2sfnet.i586.rpm
Other   ftp.sourceforge.net/pub/sourceforge/a/ac/ac-archive/OldFiles/autotools-ac.2.52.lt.1.4.2.am.1.4.5-2sfnet.i586.rpm
share|improve this answer
    
Hi and thank you for your answer, however I've already tried that with the same outcome. I reinstalled the whole libtool-ltdl package but then, when trying to install the Image::Magick package, I get the dependencies issue. –  Eugene S Apr 14 '13 at 14:50
    
what version is your copy of libtool-ltdl ? on rpm search it shows libltdl.so.3 in package CentOS 5 ftp.centos.org/5.9/os/x86_64/CentOS/libtool-ltdl-1.5.22-7.el5_4.x86_64.rpm as well as the same version for i386 –  Joe Apr 14 '13 at 14:54
    
My currently installed version is libtool-ltdl-2.2.6-15.5.el6.i686 –  Eugene S Apr 14 '13 at 14:56
    
have listed the packages that have it maybe you can install that specific version at the same time if you have other dependences that need it. Check to see if you have an older version of Image Magick. –  Joe Apr 14 '13 at 15:05

A simple yum install ImageMagick should do (it is very unlikely that it was installed without the dependencies). If the system thinks the package is installed, yum reinstall ImageMagick is the command to run. If this gives trouble, yum deplist ... gives the list of packages providing dependencies.

Also install yum-utils, check at least the manual pages for yum and package-cleanup.

share|improve this answer

Download libltdl3 package from this link, and then try to install it, it gives you libltdl.so.3. If successful go for your package installation:
rpm -Uvh ImageMagick-6.8.4-9.i386.rpm

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.