Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Issue
I have a Linux Mint installation. Every time that I boot, I need to manually mount the two partitions on my computer(New volume D and Drive C). If I don't do this, these drives don't show up anywhere. I want to know if there is some way to automate this process.

Goal
Automatically mounting all the partitions on the hard disk each time I boot.

Specs
Linux Mint 14 dual boot with Windows XP SP3

share|improve this question
add comment

3 Answers

up vote 5 down vote accepted

You can do this through the file /etc/fstab. Take a look at this link. This tutorial also has good details.

Example steps

First you need to find out the UUID of the hard drives. You can use the command blkid for this. For example:

% sudo blkid
/dev/sda1: TYPE="ntfs" UUID="A0F0582EF0580CC2"
/dev/sda2: UUID="8c2da865-13f4-47a2-9c92-2f31738469e8" SEC_TYPE="ext2" TYPE="ext3"
/dev/sda3: TYPE="swap" UUID="5641913f-9bcc-4d8a-8bcb-ddfc3159e70f"
/dev/sda5: UUID="FAB008D6B0089AF1" TYPE="ntfs"
/dev/sdb1: UUID="32c61b65-f2f8-4041-a5d5-3d5ef4182723" SEC_TYPE="ext2" TYPE="ext3"
/dev/sdb2: UUID="41c22818-fbad-4da6-8196-c816df0b7aa8" SEC_TYPE="ext2" TYPE="ext3" 

The output from the blkid command above can be used to identify the hard drive when adding entries to /etc/fstab.

Next you need to edit the /etc/fstab file. The lines in this file are organized as follows:

UUID={YOUR-UID}    {/path/to/mount/point}               {file-system-type}    defaults,errors=remount-ro 0       1

Now edit the file:

% sudo vi /etc/fstab

And add a file like this, for example:

UUID=41c22818-fbad-4da6-8196-c816df0b7aa8  /disk2p2      ext3    defaults,errors=remount-ro 0       1

Save the file and then reprocess the file with the mount -a command.

Windows partitions

To mount an ntfs partition you'll need to do something like this in your /etc/fstab file:

/dev/sda2   /mnt/excess ntfs-3g    permissions,locale=en_US.utf8    0   2
share|improve this answer
    
the two partitions /dev/sda5 and dev/sda6 are not listed in fstab file and in the blkid command. why? –  IcyFlame Apr 14 '13 at 12:42
    
okay. i got it. it is because it is a windows partition that is there in /media –  IcyFlame Apr 14 '13 at 12:45
    
Windows partitions you'll need to use the dev/sda* to mount them, also you'll need to specify ntfs-3g for the file-system-type I believe. –  slm Apr 14 '13 at 12:56
    
thanks @sim !!! –  IcyFlame Apr 14 '13 at 13:11
    
If you're all set please mark this answer as accepted so others will know it's been resolved. –  slm Apr 14 '13 at 14:07
show 2 more comments

You can do this by the simplest way. Go to:

  • Menu -> Disks (app)
  • Select the volume you want to mount, and click on its options
  • Select "Edit Mount Options" -> And make sure you select "Mount at Startup" in the drive.
share|improve this answer
    
Sometime gui makes sense or it makes easy to do these things. –  Ramsharan Oct 17 '13 at 4:11
add comment

As discussed on the previous answer, the /etc/fstab file will help you accomplish that. Please take a look at genfstab which, as suggested, uses blkid to create one automatically.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.