Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Recently I have installed openSUSE 12.3 on my Lenevo U410. I am using Windows on this machine too. But when I using openSUSE I realize that my laptop get much hotter than what is it in Windows. I also used Ubuntu before openSUSE. Ubuntu works fine, but now my fan works a little.

Do you know how to solve this?

share|improve this question
1  
What's the source of the issue? Try checking the sensors for temperature to be able to tell. My wild guess it's the GPU - if it's so, check which driver is used by Ubuntu (lsmod | grep -P 'nvidia|nouveau') and which in openSUSE. If it's the same, you may want to investigate powersaving settings. –  TNW Apr 14 '13 at 10:04
    
sorry for delayed answer. My sensors works well. I am using sensors command and get the temperatures correct. And all of them is working. About the driver, I search and find that driver. But is there a problem with using discrete GPU. My laptop has a intel GPU onboard and nvidia with optimus technology. (when laptop is idle it gets hot too, so I think this is not about GPU). –  Ramyad Apr 14 '13 at 18:48
    
I rather meant whether you know what is making your laptop so hot. –  TNW Apr 14 '13 at 18:50
    
How can I check my power saving options? –  Ramyad Apr 14 '13 at 18:54
    
Lenovo has a tool on windows. I changed it to maximize battery lifespan and therefore my battery has a strange charging behaviour in both windows and openSUSE! Is there something like that for power saving? –  Ramyad Apr 14 '13 at 18:56

1 Answer 1

up vote 0 down vote accepted

I have finally find the problem. The problem was from my discrete NVIDIA GPU. OpenSUSE 12.3 found it and all the drivers were good, but I do not know why its gets hot. I think the main problem is from Optimus technology (I have some display problems with it in Ubuntu 12.04 too!). Since I am not using my discrete GPU in Linux, therefore I have disabled it. There is two way to do this:

1.if there is no BIOS option to use UMA GPU only we must install bumblebee and required packages and then turn off discrete GPU.

2.if there is a BIOS option, we can disable Optimus. (there will be no problem with windows since it use UMA for all programs except programs you defined as "run with high-performance NVIDIA's GPU". So you can enable it from BIOS and come back to run them)

first solution: do instructions from here

second solution: go to your BIOS and disable optimus. Then come back to linux and delete all nvidia packages. Check your hardware and make sure there is no nvidia's GPU

another point: you can install YsST power management package for better controlling over power savings and therefore fan and temp of your laptop. Instructions are here

I hope someday linux will support optimus technology like windows!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.