Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to turn off password authentication for SSH after setting up public key access. I have these set in my /etc/ssh/sshd_config file:

PermitRootLogin without-password
PasswordAuthentication no
ChallengeResponseAuthentication no

However, it still lets me login with a password.

share|improve this question
add comment

1 Answer

I forgot to restart sshd, so it wasn't using the new settings. This fixed it:

/etc/rc.d/sshd restart
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.