Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I want to try the new oxygen to gtk port for kde 4.6. But I'm not sure how to enable it. I currently use qtcurve for gtk.

share|improve this question
add comment

3 Answers

up vote 0 down vote accepted

I don't know what distribution you are using, but on my Kubuntu 11.04 machines I just enable it using the System Settings / Application Appearance / GTK+ Appearance tab in the usual way, choosing Oxygen-Molecule from the Widget style dropdown list.

share|improve this answer
add comment

If I'm reading the question correctly, you want to use a GTK theme provided by KDE. All you have to do is to modify ~/.gtkrc-2.0 (there are a few applications allowing you to select the theme in a GUI, i.e. lxappearance) and start an application using GTK.

share|improve this answer
    
so kde has no built in way of enabling? –  xenoterracide Feb 11 '11 at 23:02
    
I'm afraid KDE doesn't allow you to change your GTK theme (at least not that I know of). –  Wieland Feb 12 '11 at 10:25
add comment

I believe merely having the Oxygen GTK Theme is not enough to enable it. There is a seperate KCM module for KDE which permits KDE, infecting shall we call it, GTK applications with its presence.

When installed, ( when it works that is, its not working for me right now :( ) it appears in the KDE SystemSettings in the "Application Appearance" control, and lets you

  1. Set GTK Font sizes ( either to an arbitrary size, or "match KDE" )
  2. Set GTK ColourScheme ( either to an arbitrary pallete, or "match KDE")
  3. Set GTK Widget Set ( either an arbitrary GTK theme, or the oxygen one )

On Gentoo, this module is available as kde-misc/kcm_gtk, and the metadata says the homepage is : http://gtk-qt.ecs.soton.ac.uk , however, that just gives me a dead site :/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.