Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have debian6.0 installed on my machine. It has four comports of which 2 cannot be found. From looking that the systems bios I can see that the ports address are:

PORT      ADDRESS      IRQ
1         3F8          4
2         2F8          3
3         3E8          10
4         2E8          11

Ports 1 and 2 are found by debian but 3 and 4 are not. From what I understand I can setup the ports with this information using setserial. I tried:

setserial /dev/ttyS2 port 0x03e8 irq 10 baud_base 115200

but I recieve:

/dev/ttyS2: No such file or directory

Is it safe to create a file in /dev named ttyS2? and try to run the same command again?

edit:

As per jordanm's request:

# cat /proc/devices
Character devices:
  1 mem
  2 pty
  3 ttyp
  4 /dev/vc/0
  4 tty
  4 ttyS
  5 /dev/tty
  5 /dev/console
  5 /dev/ptmx
  7 vcs
 10 misc
 13 input
 29 fb
128 ptm
136 pts
180 usb
189 usb_device
253 rtc
254 hidraw

Block devices:
259 blkext
  7 loop
  8 sd
 65 sd
 66 sd
 67 sd
 68 sd
 69 sd
 70 sd
 71 sd
128 sd
129 sd
130 sd
131 sd
132 sd
133 sd
134 sd
135 sd

EDIT:

so I made the device file with:

mknod -m 666 /dev/ttyS2 c 4 66

Than I tried to setup the com-port with:

setserial /dev/ttyS2 port 0x03e8 irq 10 autoconfig

but recieved:

/dev/ttyS2: No such device or address

There is in fact hardware for two additional serial ports.

share|improve this question
1  
dev files must be made with mknod. Show the output of cat /proc/devices –  jordanm Apr 12 '13 at 14:23
    
@jordanm I updated question with requested information –  Richard Apr 12 '13 at 15:13
    
it's Baud rate, not Boud rate. –  BatchyX Apr 12 '13 at 16:29
    
@BatchyX I know but thats how it is spelled in the bios.... :S –  Richard Apr 12 '13 at 16:30
    
If the BIOS's ACPI tables are as botched as their spelling, i would suggest updating it. –  BatchyX Apr 12 '13 at 16:43
show 2 more comments

1 Answer

in the grub bootloader I have parameter 8250.n_uarts = 4 to the boot line. After that I was able to setup serial ports using setserial

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.