Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a 2nd hard drive SDB but not sure how to mount it under linux.

mount -a did not seem to mount all.

Also would like to mount this RO for recovery.

share|improve this question

migrated from serverfault.com Apr 11 '13 at 21:10

This question came from our site for professional system and network administrators.

    
How are you trying to mount it, what does your fstab look like, and what's the partitioning scheme? –  tink Apr 11 '13 at 20:49
    
Permanently or just for temporary use? Also, has the drive been partitioned with fdisk and then formatted with newfs or mkfs? What type is the filesystem on the formatting? –  mdpc Apr 11 '13 at 21:52

2 Answers 2

mount -a mounts all filesystems in /etc/fstab.

If the drive is not yet in fstab, then it will do nothing with regard to that drive.

First, check how the disk is partitioned (e.g. with fdisk -l (that is an lowercase L, not a number 1) or with another tool such as gpart.)

If your hard drive is an LVM, these instructions won't work, stop and follow these directions: http://superuser.com/a/666034/121698

Test things with a manual mount command. Example:
mount -t ext2 /dev/sdb1 /mnt.

The contents of the first partition should now be visible under /mnt.

Note that this assumed ext2 as file system. Adjust as needed.

Note that this assumed a /dev/sdb1, it could have been /dev/sdb2, sdb3, ...
There can even be multiple partitions on that disk. Adjust as needed.

If this works: umount /mnt and add a line to /etc/fstab. Easiest is to copy one of the existing lines and adjust it. Understanding just what those values mean is recommended, so look at the top for a line like this:
Device Mountpoint FStype Options Dump Pass#

Device is the device you are trying to mount/ E.g. /dev/sdb1
mountpoint is the directory where you want the folders to show up.
FStype is the filesystem type. E.g. ext2, ext3, ext4, fat, iso9660, ...
Options are FS options, such as rw for read write, or ro for read only.
Dump and pass are for recovery. Which disk needs to be fsck'ed? In which sequence etc.

Thus... choose where you want to mount the disk. For example in /home/old_backup. It that directory does not exist then make it. (e.g. mkdir /home/old_backup). If there are already content in that directory then realise that you will not see them anymore once you mount a disk in that location. (They will show up again after you umount it, and they will still use diskspace).

Now edit /etc/fstab and add the relevant lines.

#Device       Mountpoint          FStype  Options       Dump    Pass#
/dev/sdb1     /home/old_backup    ext2    ro              2       2      

Test with mount /home/old_backup.

The next time you boot or issue a mount -a it will be automatically mounted.

share|improve this answer
1  
mount -a only mounts filesystems listed in fstab with the auto option set (which I believe is the default). Any filesystems listed as noauto won't be mounted automatically. –  Michael Kjörling Apr 12 '13 at 8:52
    
Correct. Though I never saw that auto option used anywhere, ever. (The option ro,noauto though is familiar to me, back from the time that optical drives where used) –  Hennes Apr 12 '13 at 8:53
    
That's probably because as I mentioned auto is almost certainly the default. –  Michael Kjörling Apr 12 '13 at 8:55

First you need to make sure that you have a mount directory. /mnt is what i use. (if not mkdir /mnt) Then from there you need to make sure you are mounting to correct partition by issuing the command ls /dev, and verifying the device name. After you have done this you should be able to issue the command mount /dev/sdb2 /mnt

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.