Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am actually trying to program an Atmel Evk1100 board directly from Mac OSX. My MCU is UC3A0512

I used to use Atmel32 Studio on Windows, but It looks like there no Mac Version.

So, from what I've found on Internet, I've downloaded PL2303 driver to works with my Manhattan 205146 USB to Serial converter.

Once the driver is installed, I tried it directly in ZTerm and It works without any problem with my board.

I would be able to Build project and to burn it on my board.

I've installed Avrdude andAvr Eclipse Plugin and AVR32 Studio plugin, directly from my Eclipse Juno Marketplace.

Avrdude is installed here:

$ which avrdude
/usr/local/CrossPack-AVR/bin/avrdude

So I changed the Eclipse Toolpath to works with avrdude.

But, I have this error in Eclipse: eerror message

Also, directly from avrdude, I am not able to communicate with my board.

I do:

$ avrdude -c usbtiny -p ucr2

where ucr2 is the value I got from Avrdude corresponding to:

avr dude

Bu I get this error, if I check my Environnement:

avrdude: Error: Could not find USBtiny device (0x1781/0xc9f)

avrdude done.  Thank you.

Guys, how can I program my board, directly with Eclipse and my USB to Serial cable, my board? Is it possible?

share|improve this question
    
You might also try asking about this over at electrical engineering. It doesn't seem to fall directly into either the "Ask about" or "Don't ask about" categories there, but I think it would fit under the programmer tag. There's probably more people there who've tried to use this setup. –  WhiteHotLoveTiger Dec 10 '13 at 7:20
add comment

1 Answer

I have been trying to do the same thing. Atmel has a avr32 toolchain at there website. I thought I installed it but I am going to try again.

Atmel website http://www.atmel.com/tools/ATMELAVRTOOLCHAINFORLINUX.aspx

I have also found this data sheet: "http://" www.atmel.com/Images/avr32studio_release_notea_2.6.0.pdf page three specifies some information about eclipse

More so on installing the repository "http://" distribute.atmel.no/tools/avr32studio/releases/latest/

Also I am not sure the CrossPack is compatible with the avr32.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.