Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Whenever I boot in to Linux Mint the NumLock is switched off by default. As my username consists of some numbers, I need to switch on NumLock each time. I want it to be switched on by default each time I log in.

I had a look at the following question but could not find the conf file that the author is talking about:

Enable num-lock as default in Linux

I dual boot with Windows XP and Linux Mint 14 Mate using the default US Keyboard Layout.

share|improve this question
    
The .conf they are talking about in this thread is /etc/xorg.conf, the file responsible for the behaviour of the devices during your X11-session. Do you mean log on your desktop when you 'log on'? If so, which one are you using out of the available Cinnamon, MATE, KDE, Gnome in the linux mitn distribution? – superuser0 Apr 11 '13 at 17:08
    
Tried numlockx? – schaiba Apr 11 '13 at 18:27
    
No. What is numlockx – IcyFlame Apr 12 '13 at 6:59

in Linux Mint, this is easy:
1. open up 'keyboard' in settings
2. click on the 'Layouts' tab
3. click on 'Options...'
4. Under 'Miscellaneous compatibility options' there are many helpful options, including:

  • Default numeric keypad keys
  • Numeric keypad keys always enter digits (as in Mac OS)
share|improve this answer
    
I was so excited when I found the ability to lock numlock on was built in to linux mint. – Dano Feb 21 at 6:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.