Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm having a recurrent issue with my Arch Linux installation: wireless will work for a few minutes and then randomly die. When I try to restart it through wifi-menu I am informed there aren't any networks.

 > sudo wifi-menu
:: Scanning for networks                                                [FAILED] 
 > No networks found

Running netcfg directly, I recive:

sudo netcfg wlan0-2WIRE555
:: wlan0-2WIRE555 up                  [ BUSY ] Successfully initialized wpa_supplicant
Could not set interface wlan0 flags (UP): Connection timed out
nl80211: Could not set interface 'wlan0' UP
Could not set interface wlan0 flags (UP): Connection timed out
WEXT: Could not set interface 'wlan0' UP
wlan0: Failed to initialize driver interface
> wpa_supplicant did not start, possible configuration error

The output of lspci is:

~ > lspci
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:19.0 Ethernet controller: Intel Corporation 82577LM Gigabit Network Connection (rev 06)
00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 06)
00:1c.3 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 4 (rev 06)
00:1c.4 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 5 (rev 06)
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a6)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 06)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 6 port SATA AHCI Controller (rev 06)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 06)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 06)
02:00.0 Network controller: Intel Corporation Centrino Advanced-N 6200 (rev ff)
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
ff:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
ff:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)

Every time this happens, I have to restart in order to get internet working. Is there some systemd command I can use to restart it manually? Is this an issue I can resolve permanently?

share|improve this question
    
Give us a little more info. Give us the lspci output for the wireless interface itself. lspci says this about my arch wireless interface: "05:00.0 Ethernet controller: Atheros Communications Inc. AR5212/AR5213 Wireless Network Adapter (rev 01)" –  Bruce Ediger Apr 9 '13 at 1:18
    
Thanks for taking a look. Question updated. –  wdkrnls Apr 9 '13 at 1:59
add comment

1 Answer

up vote 1 down vote accepted

I don't have a Centrino chipset machine, but I do run Arch on my laptop, and I've experimented with a lot of wireless cards and drivers.

A little googling around shows me this:

It also looks like some laptops have an external wireless switch. Ensure it's "on".

share|improve this answer
    
options iwlwifi wd_disable=1 (from the Arch linux link) seems to have done the trick. thanks! –  wdkrnls Apr 14 '13 at 20:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.