Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have Ubuntu installed on my computer. I decided to install Arch linux, but I skipped the part about Grub installation as it is already installed. Seeing that Arch does not show up in Grub's menu list, I decided to install it in Arch. I mounted Arch's partition in Ubuntu and I chrooted into it. I issued the command pacman -S grub-bios and got the following :

error: could not open file: /etc/mtab: No such file or directory
error: could not determine filesystem mount points
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.

/etc/mtab is a symlink to /proc/self/mounts, but there is nothing in the /proc folder.

What am I doing wrong?

As a complement, am I going in the right direction to make Arch appear in Grub's list? EDIT : I was able to make Arch appear in Grub's list from Ubuntu by doing sudo mount /dev/sdaX (replace X with Arch's partition number) before sudo update-grub.

share|improve this question
1  
Since in your other question you said you wanted to learn about config files, why don't you rather read how to add a GRUB entry for Arch from Ubuntu like described here(specifically at 6.) –  don_crissti Apr 6 '13 at 22:44
2  
Did you mount {/proc,/sys/,/dev} as per the wiki entry for chroot? –  jasonwryan Apr 6 '13 at 22:55
    
Yes, I now get a series of errors like this : error: failed retrieving file 'grub-bios-2.00-1-x86_64.pkg.tar.xz' from mirror.cinosure.com : Could not resolve host: (nil); Unknown error –  Gradient Apr 6 '13 at 22:59
    
But shouldn't my Arch partition be independent from the others? –  Gradient Apr 6 '13 at 23:15
2  
Did you copy /etc/resolv.conf into the chroot? Otherwise the chrooted programs don't know your DNS settings. –  t-8ch Apr 7 '13 at 9:42

3 Answers 3

up vote 2 down vote accepted

Remember to arch-chroot and not simply chroot - that way /proc will be populated and pacman will function as expected.

share|improve this answer
    
I've edited it slightly so that it doesn't sound like a comment and removed the flag :-) –  garethTheRed Aug 15 at 19:03
    
Right, thank you. I'm still not entirely used to the conventions on this site :) –  Brean Aug 16 at 10:40

Do you have IPv6 enabled? I'm unable to use pacman with IPv6 enabled on any of my machines. You should try to disable it.

share|improve this answer

Per OP's edit, he got Arch to appear in GRUB by manually mounting his Arch partition and then rerunning sudo update-grub in Ubuntu.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.