Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I use Debian Squeeze x86-64 (Kernel 3.2) with gdm3 and GNOME on a 2010 MacBook Pro.

Recently, as I tried changing the pointer configuration, I accidentally set the minimum speed of the pointer to 0 using the "Gpointing device settings" program. Now my GNOME desktop is completely unusable because the pointer will not move. I am sure that a configuration file with the pointer settings is somewhere in /etc, but editing the xorg.conf file is not an option because it does not exist on my system.

Where is this configuration file located or is there a way to circumvent default pointing-device settings?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

The easiest way of doing this is xset m. The general format is:

xset m ACCELERATION THRESHOLD

where ACCELERATION defines how many times faster the cursor will move than the default speed, when the cursor moves more than THRESHOLD pixels in a short time. ACCELERATION can be a fraction, so if you want to slow down the mouse you can use 1/2, and if 3 is slightly too fast, but 2 is too slow, you can use 5/2, etc.

For example:

xset m 1/2 4

To get the current values, use:

xset q | grep -A 1 Pointer

For more information, see here.

You should be able to log into your Gnome session, hit AltF2 to open the run dialog, type gnome-terminal and hit enter. Then run the xset command in the terminal window that appears. You can do all this without using the mouse. If, for some reason, the terminal is not focused when it opens, you should be able to switch to it using AltTab.

share|improve this answer
    
This worked very well. I just have to add the fact that I ran into the error message "xset: unable to open display ''", which turned out to be easibly fixable by SSHing into the computer with X forwarding enabled (-X flag) and executing the command there. (Just do "ssh -X localhost") –  Alex_S Apr 6 '13 at 20:16
    
Sorry, I did not notice the last part. This works well too. –  Alex_S Apr 6 '13 at 20:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.