Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to install GRUB, but when I try to boot, I get this:

error: file '/boot/grub/i386-pc/normal.mod' not found.

But that file exists on the drive I'm booting to. Why is it saying "not found" if the file is very clearly there?

I'm using BIOS, and installing everything to sdb1.

Here's my GRUB output:

GRUB loading.
Welcome to GRUB!

error: file '/boot/grub/i386-pc/normal.mod' not found.
Entering rescue mode...
grub rescue> ls
(hd0) (hd0,msdos1) (hd1) (hd1,msdos3) (hd1,msdos2) (hd1,msdos1) (hd2) (hd2,msdo
s1)
grub rescue> set
prefix=(hd0,msdos1)/boot/grub
root=hd0,msdos1
grub rescue> ls (hd0,msdos1)/
./ ../ lost+found/ var/ dev/ run/ etc/ tmp/ sys/ proc/ usr/ boot/ home/ lib lib
64 mnt/ opt/ root/ srv/ sbin/ bin/
share|improve this question
    
«trying to install GRUB» — by issuing exactly what command(s)? –  poige Apr 6 '13 at 15:12
    
@poige I originally tried grub-install --target=i386-pc --recheck /dev/sdb, then grub-install --boot-directory=/boot/ --recheck /dev/sdb, then grub-install --boot-directory=/boot/ --target=i386-pc --recheck /dev/sdb, none worked (I unsuccessfully rebooted the drive I'm installing to, then rebooted the USB with the ISO on it between tries) –  tkbx Apr 6 '13 at 15:15
1  
Very similar question (same distro) here –  don_crissti Apr 6 '13 at 15:22
    
@don_crissti and recent, too. Could it be a problem with the ISO? –  tkbx Apr 6 '13 at 15:29
    
@don_crissti added to question, just one partition and BIOS. I thought it would be extremely straightforward. –  tkbx Apr 6 '13 at 15:54
show 12 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.