Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

On waking up after standby the network (eth0) remains down. The eth0 card is r8169.

I have tried :

  • ifconfig eth0 up
    Doesn't work
  • ifconfig eth0 up; dhcpcd eht0
    Worked but how do I configure my static ip with this, my proxy is ip bound

This works:

this commands gets the network up with the conventional network manager:
modprobe -r r8169; modprobe r8169; service network-manager restart

But is there any way to automate this or modify the acpi scripts so that no modprobe is required in the first place?

Config details:

OS: Debian-squeeze (6.0)

ethtool eth0 output:

Supported ports: [ TP MII ]
Supported link modes:   10baseT/Half 10baseT/Full 
                        100baseT/Half 100baseT/Full 
Supports auto-negotiation: Yes
Advertised link modes:  10baseT/Half 10baseT/Full 
                        100baseT/Half 100baseT/Full 
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Link partner advertised link modes:  10baseT/Half 10baseT/Full 
                                     100baseT/Half 100baseT/Full 
Link partner advertised pause frame use: No
Link partner advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: MII
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: pumbg
Wake-on: g
Current message level: 0x00000033 (51)
Link detected: yes

File /etc/network/interfaces

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
#NetworkManager#iface eth0 inet dhcp
share|improve this question
    
Have you tried bringing the interface up and running the DHCP client manually? –  phunehehe Feb 9 '11 at 14:07
    
@phun I have already set up my dhcp to manual –  crodjer Feb 9 '11 at 14:50
    
Please edit the question to make your it clearer. What's the outcome that you would expect? Are you able to get the connection up and running after the sleep using, say, ifconfig eth0 up and dhcpcd eth0? –  phunehehe Feb 9 '11 at 15:21
    
@phune ifconfig eth0 up; dhcpcd eht0 worked but how can I configure it for my static ip. Also the network manager applet doesn't works either with this, i guess because now connection is being managed by other app? –  crodjer Feb 9 '11 at 15:45
add comment

1 Answer

That you have to remove and restore the device's module is an indication that it doesn't handle sleep/wakeup well. Check if there is a newer kernel available for your distribution, or compile your own.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.