Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have built cairo-1.7.6 for use in building pango-1.32.6, and I have installed it to a directory in my home directory: /home/me/local/cairo-1.7.6. Under this directory are the expected include, lib and share directories.

However, I don't seem to be able to get the pango ./configure to suck in the cairo dependency from that directory. I have tried setting the CPPFLAGS and LDFLAGS to the relevant directories, and I have looking in ./configure --help but none of the options seem obviously related.

Is there a general way to pass a locally installed library's paths to a configure script?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

You could try setting LD_LIBRARY_PATH to /home/me/local/cairo-1.7.6/lib then try ./configure --prefix=/home/me/local/pango-1.32.6

Hope this helps.

share|improve this answer
    
Looks like it was also the pkgconfig directories that were missing: /home/me/local/harfbuzz-0.9.15/lib/pkgconfig, which then caused cairo to fail to load. I changed to --prefix=/home/me/local/gtkbuild for all the deps for the build and then export PKG_CONFIG_PATH=/home/me/local/gtkbuild/lib/pkgconfig to find this "merged" directory. –  Inductiveload Apr 6 '13 at 2:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.