Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have to monitors, one attached to my Nvidia graphics card using HDMI, the other one using VGA (using a DVI-VGA adapter). Most fullscreen games (that even recognizes that there are two monitors) uses the secondary monitor. The primary monitor is correctly set when I check from nvidia-settings, xrandr or KDE system settings.

My current workaround is to simply disable monitor 2 when playing a game but that's not satisfiying. How can I effectively set the primary screen?

share|improve this question
    
Does setting the primary with xrandr help? –  derobert Apr 4 '13 at 21:20
    
xrandr already reports that it is. I guess it gets the info from the same source as the other tools. –  Erik Apr 4 '13 at 22:15
    
Could this depend on the position of the mouse pointer at the time the application goes fullscreen? –  peterph Apr 5 '13 at 7:45
1  
Depends on the game and its implementation, I guess. There are other things, like the gnome-panel ... mate-panel these days ... which defines that monitor as primary which is reported first by the graphics board. Stupid and wrong implementation, but true. Maybe your games support some command line arguments for placement and/or monitor selection? –  Bananguin Apr 5 '13 at 9:32

1 Answer 1

While I haven't been able to actually keep both screens enabled, I can at least map games to the correct screen. What I did was change the 'metamode' line in xorg.conf:

Option         "metamodes" "CRT: 1280x1024 +1920+180, DFP: nvidia-auto-select +0+0; DFP: 1920x1200, CRT: NULL"

I'm not entirely sure what the first part does, it was autogenerated by nvidia-settings. The second part however instructs the driver to realize a request for 1920x1200 resolution -- the native resolution of my primary screen, DFP -- by disabling the secondary one (CRT).

Those games that were well-behaved to begin with never actually changed the resolution to begin with but instead created a full-screen sized borderless window and placed it on the primary screen.

EDIT: This doesn't work as good as I thought, the mode isn't switched back properly later.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.