Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Everytime I start my laptop my GUI is "broken" - windows don't have the top border with close, minimize and maximize buttons. I know I can run xfwm4 --daemon but it is really bothering to do that on every startup. It used to work without any problems until last week or so. How can this be fixed?

P.S. It might be connected with my other question.

share|improve this question
    
Window manager should be started automatically, you may have a broken session. Do you have something in ~/.config/xfce4-session/? –  peterph Apr 4 '13 at 8:58
    
From the Linux Mint forums: As Xfce is modular by design all of those visual elements are actually separate processes. You can just start their process again to regain them. If you want to make sure that they are started again next time you login you should check the “Save session for future logins” in the logout dialog or check “Save session automatically on logout” in “Sessions and startup settings”. Panel xfce4-panel, Taskbar xftaskbar4 (Xfce 4.2 only), Window Manager xfwm4, Desktop xfdesktop (can depend on the dbus service, Xfce 4.4 only). See if starting any of those works. –  Alex Apr 4 '13 at 9:00
    
@peterph: Nope, I don't have any file or folder like this in .config/xfce* –  Petr Mensik Apr 4 '13 at 12:08
    
@Alex Thanks for tip, I am going to try that –  Petr Mensik Apr 4 '13 at 12:09
    
Interesting. Has the problem arisen suddenly after an update? –  peterph Apr 4 '13 at 12:15
show 4 more comments

1 Answer

up vote 0 down vote accepted

It looks like that the problem is solved by an another update (I am not experiencing this issue anymore). Nevertheless, thanks for tips.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.