Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I just got a bootable USB w/ Linux Mint 14 Nadia installed and I ran into some problems with my laptop's graphic drivers. Computer is fairly old, it's HP Compaq 6820s from around 2008. Problem actually is that when I go to Menu > Preferences > Display (in Cinnamon), there's only three options for resolution: 1152x864, 1024x768, 800x600, all of them 4:3. I need to have 1440x900 for my display and I could not find any way to do this.

I tried several approaches and I will tell what I have tried.

First of all, if I type ~ $ inxi -G following output is shown

 Graphics:  Card: Advanced Micro Devices [AMD] nee ATI RV516 [Mobility Radeon X1350]
    X.Org: 1.12.4 drivers: (unloaded: fbdev) FAILED: vesa Resolution: 1152x864@60.0hz
    GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 0x301) GLX Version: 2.1 Mesa 9.0.2

I tried using both, xrandr and xorg.conf manual setup but failed.

According to tutorial by Thinker at http://community.linuxmint.com/tutorial/view/877 I went through all the steps, however an error was shown in both cases offered.

When I give a command xrandr following error occurs: xrandr: Failed to get size of gamma for output default That is, I am unable to run xrandr --newmode "1440x900_60.00" 106.50 1440 1528 1672 1904 900 903 909 934 -hsync +vsync

So, I moved to a second approach where I needed to make xorg.conf file and put it into /etc/X11/. I did it with correct options entered, similar to what was shown in a tutorial I referred, replaced with my own values. Unfortunately, while booting (before login screen) an error came out saying that xorg.conf was mis-configured and system required fixing (i.e. deleting) it.

I tried installing drivers for ATI Mobility Radeon X1350, those were .run files that I needed to execute with root permissions, I tried about 6 different versions and none of them worked (terminal would close after a message about invalid version).

Then, I tried installing AMD Catalyst program, which did not work either, a message said there was no appropriate driver on system. This program destroyed my Mint panel (bottom panel with menu, window list and taskbar) and it became visually and funciontally different. Somehow, I uninstalled this program and after logout/login a panel got to its place.

My question is if there is a way I can set my screen to 1440x900 because eyes hurt and can't work in such environment.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.