Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I use Slackware64-current on my work laptop and though I love running Slackware, sometimes it hangs on me near to the point of starting considering falling back to Windows.

I develop on Java and use Eclipse IDE. I know Java IDE's are not supposed to be lightweight, but, on occasions, it really gets stuck and as I normally have a console open, I run top only to find out Java is taking 90%+ of CPU load.

How can I make sure it does not gets (much!) in my way?

I know this is a rather open question, but I'll be more than happy to provide more details as needed.

EDIT: Hardware specs

CPU: Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz
RAM: 4GiB (probably DDR3, not sure though!)
share|improve this question
1  
Unrelated to your problem but, if you're teetering on the edge with Windows, maybe you're using the wrong distro. There are other more modern distros that you're probably going to have more success and an easier time with.**To address your concern though**: You can increase the "nice" value of the IDE. This wouldn't decrease load the IDE is generating but it would make it so the IDE will cede more time to other applications rather than driving the system to its own ends. Ultimately, though the IDE is just telling the system it needs to do this much work so Linux is complying with the request. –  Joel Davis Apr 3 '13 at 17:58
1  
It's worth pointing out that this behavior is fairly common on windows as well. I've gone into task manager and seen the CPU indicators topped out at 100% many many times before. Switching platforms isn't going to avoid problems of runaway applications. –  Joel Davis Apr 3 '13 at 18:00
    
What are your hardware specs? –  schaiba Apr 3 '13 at 18:19
    
java in itself if not the one to blame. What is the associated program that is using it? For instance, if you are using JBOSS it will be a java process, glassfish as well and for you to know which one you need to see the full argument list. Have you tried to see what is the associated program? –  BitsOfNix Jun 18 '13 at 21:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.