Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've been looking around the site but I couldn't find anyone with the same problem. On VirtualBox, I have a machine with IP *.28 and another one with IP *.20. The latter should mount a directory exported by the former.

*.28:/etc/exports

/myfolder *.20(rw,sync,no_root_squash,subtree_check)

*.20:/etc/fstab

*.28:/myfolder /myfolder nfs defaults 0 0

The recipient just does not mount the directory at startup. When I try to manually mounting via: mount /myfolder

I get this error message:

mount: wrong fs type, bad option, bad superblock on *.28:/myfolder,
missing codepage or helper program, or other error
(for several filesystems (e.g. nfs, cifs) you might
need a /sbin/mount.<type> helper program)

Any idea why this happens? (Or where I can get this "helper program" that I'm apparently missing?)

share|improve this question
    
so it turns out I'm ACTUALLY missing mount.nfs, which should be part of nfs-common or some other package...does anyone know which one exactly? –  blue Apr 1 '13 at 15:04
    
Which distro are you running? That'd let us figure which package its in. –  derobert Apr 1 '13 at 16:06
    
debian squeeze! –  blue Apr 1 '13 at 19:04
    
nfs-common is the package name. You can find these at debian.org/distrib/packages#search_contents or using apt-file... –  derobert Apr 1 '13 at 20:15

1 Answer 1

up vote 1 down vote accepted

Just to be sure I would start checking the basics:

  • Can you ping the other machine? If not you're probably facing a network problem.
  • Can you telnet the port nfs is using on the server? If not then maybe is a firewall issue or nfs misconfiguration.To see port info you can use the command (in the nfsserver):

    rpcinfo -p
    

If those things are right then try (from the nfs client):

   showmount -e *.28

You should see the /myfolder exported to whatever network * is. If not then there is a problem with the nfs server configuration.

PD: I think you should add the option _netdev to the fstab line so it does't try to do the mount till the network is ready. Anyway if manual mounting fails that's not the problem.

share|improve this answer
    
It does ping and there's no firewall. It appears that for some reason I was missing /sbin/mount.nfs. I'm currently reinstalling the client's filesystem from scratch, taking care to include nfs-common, which should provide said mount.nfs. Thank you for your help! –  blue Apr 1 '13 at 15:31
    
reinstalling the entire OS seems like overkill. –  Joel Davis Apr 1 '13 at 23:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.