Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have Windows 7 installed, and headphones work perfectly. Few days ago, I installed Arch Linux along with Win7. This issue appears with gnome/xfce4/openbox. Perhaps it is not related to desktop environment

My headphones work fine under Arch Linux but:

  1. When I turn to Win7 from Arch Linux, headphones stop working.
  2. When I reboot Win7 twice, headphone works.
  3. When I use halt -p, from Arch Linux and reboot to Win7, headphone works fine.

I am using plain headphones(not usb headphone). Here is my device

00:1b.0 Audio device [0403]: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio [8086:3b56] (rev 05)

01:00.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Redwood HDMI Audio [Radeon HD 5000 Series] [1002:aa60]
share|improve this question
    
What's your hardware ? –  don_crissti Apr 5 '13 at 21:43
    
Acer 4820T, HDA-Intel - HD-Audio Generic –  jilen Apr 6 '13 at 8:50
    
Are you using a USB headphone, or just a plain headphone that is connected via TRS phone connector to your sound card/mainboard? If it's the latter, it's not your headphone that is not working, but the sound card itself. –  Martin von Wittich Sep 21 '13 at 13:24
    
Also, please post the output of lcpci -nn so we know exactly what type of sound card you are using. If you are using a USB headphone, please post the output of lsusb. –  Martin von Wittich Sep 21 '13 at 13:25
    
@MartinvonWittich I add hardware info to the question, could you just have a look at that? –  jilen Sep 21 '13 at 16:05
show 2 more comments

2 Answers

I can not say for sure what the problem is but after doing a little research I do have some suggestions:

No-1. It could be that you're using the wrong default audio device as it's probably defaulting to HDMI. Disable HDMI audio or just set another default device.

No-2. It could be you are using the wrong sound codec in the modprobe conf. You might find something about that here → https://bbs.archlinux.org/viewtopic.php?pid=1273556#p1273556 .

No-3. Check to see if anything is muted. Try using alsamixer to unmute everything.

No-4. Try installing OSS = "Open Sound System". I know nothing much about it but have read other people with same type of problem say they fixed it with this. More info on OSS.

Here → http://www.opensound.com/

Hope some of this helps... Good Luck!

share|improve this answer
add comment

Same thing was happening to me until I found out what was the problem. Open your Audio Mixer and click the Select Controls button. There you will find several options but there is one that says Auto-Mute Mode. Check that and you will have a new tab where you can disable the auto-mute mode. Hope it works.

share|improve this answer
    
What does the audio mixer actually means ? Windows mixer or gnome mixer or alsa mixer or something else ? –  jilen Jan 12 at 12:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.