Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am using Linux Mint KDE Nadia 14 64bit version. When I run software-center, it dosen't work, following errors appear:

huseyin@huseyin-GA-MA770-UD3 ~ $ software-center
2013-03-31 23:00:24,688 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2013-03-31 23:00:24,697 - softwarecenter.db.database - INFO - open() database: path=None use_axi=True use_agent=True

2013-03-31 23:00:25,270 - softwarecenter.region - WARNING - failed to use geoclue: 'org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Geoclue.Master was not provided by any .service files'
2013-03-31 23:00:25,521 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2013-03-31 23:00:25,531 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/gi/importer.py', 51, 'find_module')'
2013-03-31 23:00:25,531 - root - ERROR - Could not find any typelib for LaunchpadIntegration
2013-03-31 23:00:25,628 - softwarecenter.ui.gtk3.app - INFO - show_available_packages: search_text is '', app is None.
2013-03-31 23:00:25,631 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()

(software-center:5515): Gtk-CRITICAL **: gtk_widget_get_toplevel: assertion `GTK_IS_WIDGET (widget)' failed
Traceback (most recent call last):
  File "/usr/bin/software-center", line 182, in <module>
    app.run(args)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 1387, in run
    self.show_available_packages(args)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 1325, in show_available_packages
    self.view_manager.set_active_view(ViewPages.AVAILABLE)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/session/viewmanager.py", line 151, in set_active_view
    view_widget.init_view()
  File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/availablepane.py", line 139, in init_view
    SoftwarePane.init_view(self)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/softwarepane.py", line 138, in init_view
    self.icons, self.show_ratings)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/views/appview.py", line 70, in __init__
    self.helper = AppPropertiesHelper(db, cache, icons)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/models/appstore2.py", line 108, in __init__
    self.all_categories = cat_parser.parse_applications_menu()
  File "/usr/share/software-center/softwarecenter/db/categories.py", line 277, in parse_applications_menu
    category = self._parse_menu_tag(child)
  File "/usr/share/software-center/softwarecenter/db/categories.py", line 471, in _parse_menu_tag
    query = self._parse_include_tag(element)
  File "/usr/share/software-center/softwarecenter/db/categories.py", line 429, in _parse_include_tag
    xapian.Query.OP_AND)
  File "/usr/share/software-center/softwarecenter/db/categories.py", line 366, in _parse_and_or_not_tag
    operator_elem, xapian.Query(), xapian.Query.OP_OR)
  File "/usr/share/software-center/softwarecenter/db/categories.py", line 412, in _parse_and_or_not_tag
    q = self.db.xapian_parser.parse_query(s,
  File "/usr/share/software-center/softwarecenter/db/database.py", line 185, in xapian_parser
    xapian_parser = self._get_new_xapian_parser()
  File "/usr/share/software-center/softwarecenter/db/database.py", line 211, in _get_new_xapian_parser
    xapian_parser.set_database(self.xapiandb)
  File "/usr/share/software-center/softwarecenter/db/database.py", line 177, in xapiandb
    self._db_per_thread[thread_name] = self._get_new_xapiandb()
  File "/usr/share/software-center/softwarecenter/db/database.py", line 190, in _get_new_xapiandb
    xapiandb = xapian.Database(self._db_pathname)
  File "/usr/lib/python2.7/dist-packages/xapian/__init__.py", line 3666, in __init__
    _xapian.Database_swiginit(self,_xapian.new_Database(*args))
xapian.DatabaseOpeningError: Couldn't stat '/var/cache/software-center/xapian' (No such file or directory)
share|improve this question

1 Answer 1

I came here via google looking for the answer to this same problem on Ubuntu 12.04. The solution that worked for me was to run:

sudo update-software-center
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.