Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How can I have the same emacs fonts and antialiasing configuration that I have in my local Ubuntu 12.04 also working when I open an emacs session via ssh to a CentOS 5 system?

EDIT: I didn't get an answer for this and it's still bothering me. I have emacs 24 installed, so I thought it should have been easy to have good quality fonts with antialiasing enabled...

share|improve this question

Check out http://www.emacswiki.org/emacs/RemoteEmacs#toc9 (How to make sure fonts on the remote application are in sync with what you have on your local display?).

By isolating all font-settings into the X11 server’s resource database. It is quite a versatile system, where generic settings can conditionaly be made. xrdb(1x), the program to access the database, filters via cpp(1) preprocessor, and sets some defines to choose behaviour upon. tekonivel does this, and also sets all the colours into the XRDB too. With X11 the xrdb doesn’t need to run on the same machine as the X11 server, so all configuration can be made from the same machines where the Emacs will be running from, if need be. Tools exist to ask which fonts the X11 server has (f.ex. xlsfonts(1)), thus these preferences may be programmed.

share|improve this answer
Generally answers are preferred to be self-sufficient. Could you please add the relevant info from the link that solves the problem to your answer? – N.N. Apr 9 '13 at 8:22
I followed the instructions under xrdb and did a xrdb -merge ~/.Xdefaults but there is no change in the fonts... – 719016 Apr 9 '13 at 12:41
Did you restart X after that? – devnull Apr 9 '13 at 13:06
on the client I did, on the server, I can't, I don't have permissions. – 719016 Apr 13 '13 at 4:24

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.