Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm running a Debian 6.0. I connected an HP 1000 J110 to my server which I access via SSH. Listing the USB ports it recognized it. Also I Pasted the PPD on the /etc/cups/ppd/ folder. Is the PPD my PC uses to print when attached directly to the PC. I installed another printer and had no problem.

I Use lpstat -p and it shows the printer there :

printer DESKJET-1000-J110 is idle.  enabled since Fri 22 Mar 2013 08:05:33 PM UTC

Then I use:

lp -d DESKJET-1000-J110 filetoprint.txt

where DESKJET-1000-J110-111 is the request id (1 file), and it appears that the file is sent to the printer. It actually appears as completed, but it just doesn't print anything.

I also tryed with HPLip And when trying to run hp-setup it says:

error: No device selected/specified or that supports this functionality.

I checked and this printer is supported by HPLip. What am I missing? I can post any additional needed info

share|improve this question
1  
Check /var/log/cups/error_log. If it doesn't say anything, up the LogLevel in /etc/cups/cupsd.conf. Also, what user did you run hp-setup as? Did said user (if non-root) have access to the USB port? It should work: hplipopensource.com/hplip-web/models/deskjet/… –  derobert Mar 29 '13 at 18:38
    
Thank you a lot... that error log helped me a lot... I resolved the problem... actually I have tryed already what solved the problem... i'm a little confused... but it work now. I'll post my solution –  AAlvz Mar 29 '13 at 19:14
    
@derobert Another thing.. I'm using this printer for multiple clients and I use the IP as reference. How can I use a hostname for the server to make this? I'm using the hostname that is in the /etc/hostname file of my server. But no pc can find it... is it ok this way? –  AAlvz Mar 29 '13 at 20:04
    
If they're running CUPS, you should be able to publish the printer on the server, then turn on browsing on the clients, and it'll automatically work. Other than that, you need to get the hostname resolvable—e.g., add it to your DNS server. If they're Windows clients, you can also use Samba. I suggest opening a new question with full details if that doesn't answer it. –  derobert Mar 29 '13 at 20:06
    
Yes, browsing is on.. i need to make some tests. Thank you a lot –  AAlvz Mar 29 '13 at 20:13
add comment

2 Answers 2

up vote 0 down vote accepted

The solution was not that complicated. I used the following code: (Erased before the existing printers using lpadmin -x PrinterName)

To view my URI:

lpinfo -v

I got this:

:~# lpinfo -v
network http
network socket
direct scsi
network lpd
network ipp
serial serial:/dev/ttyS0?baud=115200
direct usb://HP/Deskjet%201000%20J110%20series?serial=CN19S21RWB05D2
network beh

The direct usb part is the URI.

I had already a ppd file. So I copied it to /etc/cups/ppd/

Then I added the printer using:

:~# lpadmin -p Deskjet-1000-J110-series -E -v usb://HP/Deskjet%201000%20J110%20series?serial=CN19S21RWB05D2 -m /etc/cups/ppd/Deskjet-1000-J110-series.ppd 

I got this error: lpadmin: Unable to copy PPD file!

As it was already specified (the ppd file) .. I ran a test

lp -d Deskjet-1000-J110-series fileToPrint

And.. printed...

share|improve this answer
add comment

To install HP All in One go to terminal:

wget http://prdownloads.sourceforge.net/hplip/hplip-3.13.11.run
chmod +x hplip-3.13.11.run
sh hplip-3.13.11.run

for root password type in terminal:

sudo passwd root
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.