Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've installed GNOME 3 in Mint 14 with sudo apt-get install gnome-shell but now I have a problem. The general functionality is ok, but the windows look like the windows in Mint or rather like the windows in "GNOME (default) 2D":

enter image description here

And worse than that is the right-clicking-menu of the windows! For some reason my screenshot program is not able to make a screenshot of that menu.

And a second question: On the Gnome extensions page only 3 pages of extensions are available. Did I forget to install any packages?

Update:

I've also installed the following packages:

sudo apt-get install gnome-shell gnome-session gnome-tweak-tool
sudo add-apt-repository ppa:webupd8team/gnome3
sudo apt-get update && sudo apt-get install gnome-shell-extensions gnome-shell-extensions-common
share|improve this question
add comment

2 Answers

This link shows that there are a few packages more you need to install (gnome-session gnome-tweak-tool) then add one of the suggested PPAs for extensions.

share|improve this answer
    
It gives me the Error, that it couldn't find gnome-shell-extensions-common ...and nothing changed –  Jere Mar 28 '13 at 14:48
1  
Please don't name you link this link or here. Give it a useful name like Linux Mint forum or Wikidpeia - FooBar. Second: Please provide the gist of the information found on the page. In case the link dies this answer becomes obsolete as well. –  Marco Mar 28 '13 at 14:57
    
@Jere: did you add the PPAs as suggested there? And performed an 'apt-get update'? –  schaiba Mar 28 '13 at 15:12
    
yes. and there were no errors... –  Jere Mar 28 '13 at 15:25
    
@Marco Apologies; my edit introduced the generic link name when I uploaded the screenshot and I didn't change it. –  John Bensin Mar 29 '13 at 2:47
show 3 more comments

I suppose, that your session does not start Mutter or Metacity, but uses Mint's default Muffin Window Manager instead.

You might need to change your session file, e.g. /usr/share/gnome-session/sessions/gnome.session and set Mutter as your DefaultProvider-windowmanager, see this link for instance:

Could you supply your process tree with ps axjf, so that we could see, what processes are started in your X session with what args? For instance, here is my gnomish fragment of ps axjf and note that I have gnome-session started with --session gnome-fallback and also metacity as window manager.

 /usr/sbin/gdm3
  \_ /usr/lib/gdm3/gdm-simple-slave --display-id /org/gnome/DisplayManager/Display1
      \_ /usr/bin/Xorg :0 -br -verbose -novtswitch -auth /var/run/gdm3/auth-for-Debian-gdm-kcllLB/da
      \_ gdm-session-worker [pam/gdm3]
          \_ gnome-session --session gnome-fallback
              \_ /usr/bin/ssh-agent /usr/bin/dbus-launch --exit-with-session gnome-session-fallback
              \_ /usr/lib/gnome-settings-daemon/gnome-settings-daemon
              \_ /usr/bin/metacity
              \_ gnome-panel
              |   \_ iceweasel
              |   \_ gnome-terminal
              |       \_ gnome-pty-helper
              |       \_ bash
              |           \_ ps axjf
              \_ /usr/lib/gnome-disk-utility/gdu-notification-daemon
              \_ /usr/lib/tracker/tracker-miner-fs
              \_ /usr/lib/tracker/tracker-store
              \_ /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
              \_ gnome-screensaver
              \_ /usr/lib/gnome-settings-daemon/gnome-fallback-mount-helper
              \_ bluetooth-applet
              \_ /usr/lib/evolution/3.4/evolution-alarm-notify
              \_ gnome-sound-applet
              \_ /usr/lib/notification-daemon/notification-daemon
              \_ nm-applet
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.