Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I would like to mount a folder from the remote server 10.12.13.2.

When I type: mount -F nfs 10.12.13.2:/username /remote/username, the folder username gets mounted in the directory /remote/username.

Now I would like to make an entry in the /etc/vfstab, but without mount at boot.

10.12.13.2:/username   -       /remote/username       nfs     -       no      rw

Now, how can I mount the directory?

When I type mount /remote/username, I always get: mount: mount point cannot be determined

share|improve this question
    
double check the vfstab entry. that messages means that he cannot find the entry in the vfstab Ensure that the /etc/vfstab is properly configured (recommended tabs between fields) –  BitsOfNix Mar 28 '13 at 1:03
1  
Does the mountpoint exist? Are you inadvertently including a trailing slash that tab-completion can append? I.e., are you running "mount /remote/username/" instead of "mount /remote/username"? –  Tim B Mar 28 '13 at 11:37

3 Answers 3

This should work, assuming you didn't disable the default /net automount:

ln -s /net/10.12.13.2/username /remote/username
ls -l /remote/username
share|improve this answer

I think on solaris nfs mounts should be placed in /etc/dfs/dfstab. Take it with a grain of salt, a large one at that, as Solaris is not my forte. But I remember something like this. Hope this helps

share|improve this answer
1  
dfstab is for exports. –  Tim B Mar 28 '13 at 11:32

check that the /remote/username directory exists. If it doesn't, you'll need to create the empty placeholder directory, and then try your 'mount /remote/username'.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.