Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I used to be able to have my USB stick auto-mount when I plugged it in, on my GNOME desktop. After some fiddling with my system, it doesn't happen anymore. I now have to resort to doing this using the command line.

Here's the Window that appears when I stick it in:

enter image description here

Here's the end of dmesg output:

[20500.548090] usb 2-3: new high speed USB device using ehci_hcd and address 6
[20500.703390] usb 2-3: New USB device found, idVendor=8564, idProduct=1000
[20500.703399] usb 2-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[20500.703406] usb 2-3: Product: Mass Storage Device
[20500.703411] usb 2-3: Manufacturer: JetFlash
[20500.703416] usb 2-3: SerialNumber: 64V6ZJ34LRL69IU1
[20500.703868] usb 2-3: selecting invalid altsetting 1
[20500.704828] scsi8 : usb-storage 2-3:1.0
[20502.122302] scsi 8:0:0:0: Direct-Access     JetFlash Transcend 8GB    1100 PQ: 0 ANSI: 0 CCS
[20502.123693] sd 8:0:0:0: Attached scsi generic sg2 type 0
[20502.125043] sd 8:0:0:0: [sdb] 15826944 512-byte logical blocks: (8.10 GB/7.54 GiB)
[20502.125774] sd 8:0:0:0: [sdb] Write Protect is off
[20502.125782] sd 8:0:0:0: [sdb] Mode Sense: 43 00 00 00
[20502.125789] sd 8:0:0:0: [sdb] Assuming drive cache: write through
[20502.132333] sd 8:0:0:0: [sdb] Assuming drive cache: write through
[20502.133529]  sdb: sdb1
[20502.135252] sd 8:0:0:0: [sdb] Assuming drive cache: write through
[20502.135257] sd 8:0:0:0: [sdb] Attached SCSI removable disk
[20502.658377] UDF-fs: No anchor found
[20502.658380] UDF-fs: Rescanning with blocksize 2048
[20502.682376] UDF-fs: No anchor found
[20502.682379] UDF-fs: No partition found (1)
[20502.738750] ISOFS: Unable to identify CD-ROM format.
share|improve this question
    
This can be done in a number of ways. Which one is preferred/best/recommended/easiest is distribution-specific. –  mattdm Feb 7 '11 at 17:32

2 Answers 2

up vote 1 down vote accepted

So I went and tried mounting the USB stick with pmount /dev/sdb1 /mnt/blah and it it gives a more useful message than the GUI dialogue:

Warning: device /dev/sdb1 is already handled by /etc/fstab, supplied label is ignored
mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

This led me to find that "/etc/fstab" actually has an entry for /dev/sdb1:

/dev/sdb1       /media/cdrom0   udf,iso9660 user,noauto     0       0

The reason for this is that my stick was actually attached while installing Debian Squeeze, and so got automatically added in there. That's what will happen when you install from the same stick, and now I'm curious how others avoid this problematic situation.

share|improve this answer
    
That was my first guess, since it seems to be taken as a cdrom drive. –  Keith Feb 7 '11 at 22:30

Looks like your USB stick has a hidden partiton that acts as a CD-ROM drive. You might need to look for a Windows utility from the manufacturer that can remove that, unfortunately.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.