Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am creating a cloning script to automate a minimalistic installation of Cent OS 5.5 on about 100 workstations of various hardware and age (2-10 years). The workstations are all either IDE or SATA.

I am currently developing the script and testing it on VMs (ESXi 4) with virtual IDE disks. In the initrd I have commented out scsi_mod.ko, sd_mod.ko & scsi_transport_spi.ko, and it seems to work just fine for booting a VM that uses an IDE disk. The problem is that I don't have easy access to the physical workstations and there are no virtual SATA disks for ESXi, so I cannot test with SATA disks.

Are the above SCSI modules needed on a workstation that only has a SATA disk? Are any SCSI modules needed for SATA disks (with a stock CentOS 5.5 kernel)?

Thanks,
Lars

share|improve this question
    
Most random-access storage drivers use SCSI somewhere, because most devices speak SCSI at some level. See Why do my SATA devices show up under /proc/scsi/scsi ?, and I think I've seen more precise answers, maybe on another Stack Exchange site. –  Gilles Feb 9 '11 at 22:45
add comment

2 Answers

The SATA driver uses the SCSI kernel modules. You'll need scsi_mod and sd_mod at least, I'm not sure about scsi_transport_spi, it's certainly not loaded on any of my SATA-only systems.

share|improve this answer
    
Ok, thanks for the help! –  Lars Feb 6 '11 at 18:51
add comment

Depends on the chipsets involved, you may need a chipset-specific driver to get at your SATA drives.

Perhaps you might want to look into kickstart, which lets you define how you want the system to end up looking, then does a fresh install of CentOS to that specification -- including any required kernel modules.

share|improve this answer
    
Thanks for the input, but I have included all SATA modules in the initrd to be safe. I cannot easily use a jumpstart installation due to a lot of older hardware without a CD-ROM drive as well as slow WAN links. A cloning script works much better in this scenario. –  Lars Feb 10 '11 at 4:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.