Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've created a virtual machine with Ubuntu (having TinyOS). The problem arises when I start the machine. I immediately get a black screen with written:

GRUB loading.
error: invalid arch independent ELF magic
grub rescue>

What kind of a problem is it, and more importantly how can I solve it? I tried it on my laptop which has Windows 7 64 bit, and so I also tried it on my Ubuntu partition and also with Ubuntu, once I launch the virtual machine I get the same error!

share|improve this question
1  
What architecture(s) do your host and guest have? This may simply be a case of 64-bit support not being enabled for virtual machines. –  Joseph R. Mar 26 '13 at 20:22
    
im running virtual box on a window 7 64 bit, while the TinyOS ubuntu is 32 bit! –  Hassan Samii Mar 27 '13 at 9:25
    
Then you may be looking at the opposite case. Check the processor settings of the virtual machine. Are you trying to install 32-bit TinyOS on a 64-bit VM? It doesn't seem that the installation should fail though... –  Joseph R. Mar 27 '13 at 19:40
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.