Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I need help configuring the Samba server so I can connect from a Windows (edit Windows 7) machine to my Fedora. I followed several tutorials because and non of them work for me. Here are two of them:
tutorial 1
tutorial 2
tutorial 3 (samba and selinux)

Here is the fpaste of my Samba configuration file.

When accessing my machine by IP Windows machines see the shared folders allusers and Share.

  1. When trying to open allusers folder it asks the user to provide username and password. I've created a test user and added it to users group + samba's users but it's not working with it (meaning It doesn't accept it).
  2. When user tries to open the Share folder there is a message saying that he doesn't have permissions to open the folder. The folder is in 777 mod + SELinux is disabled + I allowed the Samba, Samba Client, Echo Reply (pong) and Echo Response (ping) to pass the firewall.

Can you point where is my mistake or give me some direction, please? Thanks in advance.

share|improve this question
What version of windows are you running? I'm going to guess 7 – midnightsteel Mar 25 '13 at 14:12
Your guess is correct. Windows 7. – Maistora Mar 25 '13 at 14:16
up vote 1 down vote accepted

Provided that you are running Windows 7. Do the following

Run gpedit.msc Console Root -> Local Computer Policy -> Computer Configuration -> Windows Settings -> -> Security Settings -> Local Policies ->Security Options Microsoft network client: Send unencrypted password to third-party SMB server: Switch it to "Enabled". Network security: LAN Manager authentication level: Select the option: Send LM & NTLM - use NTLMv2 session security if negotiated.

share|improve this answer
I tried it just now but no result... :( Still getting the "..you do not have permission to access" – Maistora Mar 25 '13 at 14:24
I had a problem with the security mod - it was set to share but when change it to user and added new user to samba it worked. Thanks for the settings. It helped a lot :) – Maistora Mar 26 '13 at 9:28

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.