Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.
$ sudo apt-get install mono-runtime
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 linux-image-generic-pae : Depends: linux-image-3.2.0-38-generic-pae but it is not going to be installed
 mono-runtime : Depends: mono-gac (= 2.10.8.1-1ubuntu2.2) but it is not going to be installed
                Recommends: binfmt-support (>= 1.1.2) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I'm trying to install McMyAdmin on Ubuntu 12.04, but I can't install mono. What's the problem? Should I backup the server files and reinstall?

Edit: Here's sources.list; sources.list.d is empty.

share|improve this question
6  
You might want to run 'apt-get -f install' to correct these:. Did you try what the output suggested? –  jordanm Mar 24 '13 at 5:38
    
Yes I did, and it still says the same thing. –  user104323 Mar 24 '13 at 5:51
1  
Issue apt-get update first –  warl0ck Mar 24 '13 at 5:55
3  
BTW, this isn't a problem with the kernel, it is something screwed up with the package management system. The kernel it is referring to is just an optional package (that you don't need). –  goldilocks Mar 24 '13 at 6:27
    
Add your sources.list and everything in sources.list.d to the post please. Looks like you have enabled some dodgy repos. –  Dennis Kaarsemaker Mar 24 '13 at 10:03

1 Answer 1

-f means fix-broken be sure you already purge or remove or install not canonical. for doing continue you should use -f to fix your problem. such as apt-get -f dist-upgrade

share|improve this answer
    
I'll try apt-get -f dist-upgrade once I boot up the server. –  user104323 Mar 24 '13 at 5:52
    
after apt-get -f dist-upgrade try to dpkg -a --configure –  Mohsen Pahlevanzadeh Mar 24 '13 at 6:20
    
E: Sub-process /usr/bin/dpkg returned an error code (1) –  user104323 Mar 25 '13 at 14:33
    
When you get error after loop of dpkg and apt-get, you should see what say dpkg : preinst or postinst and so on. then you can manipulate its file. –  Mohsen Pahlevanzadeh Mar 27 '13 at 19:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.