Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For developing web sites, I define test domains in /etc/hosts : example.org

I can then access example.org in the browsers.

However I when the Network Manager is not connected to any network, Firefox is not able to access example.org, it gives an error similar to DNS failure. It cannot even load the localhost, if I try to access it by the host name of my machine - i.e. http://rohit-box.

I can access example.org, rohit-box, etc. in Chrome. I can also ping them successfully. Thus I have isolated the problem to Firefox.

I am using Linux Mint 13 Cinnamon, Firefox 19.

Edit - I also tried resetting Firefox from the Help menu. The issue persists.

share|improve this question
Does the problem persist when you restart Firefox while NM is disconnected? – peterph Mar 22 '13 at 20:22
@peterph,Yes the problem remains even if I restart Firefox. – Rohit Mar 23 '13 at 4:03

It appears firefox has switched to "Offline Mode", based on the Network Manager's reported status. You can disable this behaviour by setting "toolkit.networkmanager.disable" (all lowercase) to true in about:config.

More info here

share|improve this answer
The preference did not exist, so I added it. However, the problem was not fixed. – Rohit Mar 24 '13 at 5:34
I checked the Offline item in the File menu - Firefox doesn't go into "offline mode" in this situation. – Rohit Mar 24 '13 at 5:55
Same answer as other guy, kind of: the key is toolkit.networkmanager.disable (note the lower case here). – CameronNemo Jun 29 '14 at 11:13

add your domain to your ipv6 localhost example.org

::1     ip6-localhost ip6-loopback example.org
share|improve this answer
Tested using Firefox 32 on Linux Mint 17. Does not work. – Rohit Sep 25 '14 at 15:25

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.