Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top
rfkill list all


0: fxi_c210-bt: Bluetooth
     Soft blocked: no
     Hard blocked: no

And hcitool dev shows nothing except:


Bluetooth didn't work, but at some start it didn't work anymore. I already tried to restart and tried to restart the bluetooth service.

Problem is on a linaro-ubuntu version.

share|improve this question
up vote 1 down vote accepted

Somehow the .hcd-file for the bluetooth device in the folder /lib/firmware got corrupted. I replaced it and it works again. Now hci0 shows up and bluetooth works.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.